Display: Render Only -> Hiding a mesh

I would like to make a viewport render of a certain scene and for that I want to hide all the lights & relationship lines using the “Render Only” option in my Display panel.

In my entire project there is 1 single object that get’s hidden when I tick that “render only” checkbox and I honestly have no clue why it’s happening.

Can anyone tell my why this is happening?

If you look in the outliner window, the camera icon (object renderability) for that object is greyed out. Turn renderability back on by mouse clicking on the icon.

I knew it was going to be something that simple, I was looking for a similar option in all of the properties.
Thanks man, I probably clicked it by accident.