dissapearing shadow act (3 pics included)...helllp

i have an arch model with structural members-the members should cast shadows onto themselves. i dont want to put a plane under the model, i just want the model to float and show the shadows that it casts onto itself internnally. but the shadows wont render unless there is a plane under the model…
i don’t understand why this model wont show shadows unless there is a plane underneath it…auuughhh.

the problem is with blender internal - yafray isnt doing this at the moment.

i included a screenshot and the two sample renders…im baffled.

(by the way…does anybody know how to import several .3ds files at once, i posted the question yesterday, but haven got any bites yet…pleaaase, don’t you think that would totally rock?)

[img]http://us.f13.yahoofs.com/bc/43b3f53a_a6eb/bc/blender+files/no+shadows.jpg?bfw0_sDBquX4e01w

[img]http://us.f13.yahoofs.com/bc/43b3f53a_a6eb/bc/blender+files/shadows.jpg?bfw0_sDBGPE5mdrh

ok, im a uber-retard…can anyone tell my why my pics didnt show?

I can’t tell you why the shadows aren’t working (I’m having my own problems with shadows not casting onto a plane) but the pics aren’t showing because the yahoo url isn’t good. I mean - its not your fault, but yahoo doesn’t like remote linking.

Try photobucket or something like that. :slight_smile:

http://i25.photobucket.com/albums/c77/originalsurfmex/shadows.jpg

http://i25.photobucket.com/albums/c77/originalsurfmex/noshadows.jpg

http://i25.photobucket.com/albums/c77/originalsurfmex/MWSnap001.jpg

thanks dude!..now that my post is a little less uber retarded…please let the advize flowwwwwww

What sort of lamps are you using? Raytraced shadows? Buffered?

If you look close at the second picture, you can see parts of shadow. Do a test render with the camera closer to an area where shadow should be to be sure that shadows are rendered.

ok, did that close up test render, and its the same thing only bigger, lol. your right its not that theres “no shadows” theres just like shadow fragments, incomplete shadows.

my lamp is a sun with “ray shadow” clicked on.

Those little bits of shadow suggest this is a ClipSta problem. Set your ClipSta and ClipEnd settings as close as possible to the model and see if this helps. Also keep your SpotSi as low as possible (narrower beam - usually between 30-50 degrees).

I can’t see how just adding a plane and making no other changes would affect this though.

my clipsta is at .1 and my clipend is at 1000.00

…rendered again and no dice.

c’mon guys!!! pleeez, there’s gotta be some more ideas…i don’t wanna be restricted to yafray here.

Strange. Normally adding or deleting an underlying plane shouldn’t change anything in the shadows. Are you sure you’re lightsettings are correct. (try rendering the scene with a simple spotlight instead of te sun and the arealight). Or maybe there is an additional light somewhere out of view.

yeah, the plane thing has me straight baffled - i just added cuz i had this nagging “what if” feeling.

ok, so i checked…i deleted my only other light in the scene, that made no difference. i changed to a spot light and ended up with no shados instead of fragments of shadows. i used both ray and buffered shadows (with the buffer over 3000 and the clip start and clip end encompassing my model).

man, this is driving me nuts, i mean why would yafray work fine with the exact same settings?..i need the speed of blender internal here.

any more ideas? plz dont give up on me now, im too weak and dumb to survive outside of the thicket.

Can you post the blend?

GreyBeard

ClipSta needs to be as close to the MODEL as practical. ClipEnd also has to be close. 0.1 to 1000 is the opposite of this - they are both (presumably) a loooong way from the model.

I can’t suggest values because every model is different. Adjust ClipSta until the ClipLine displayed in the viewport is pretty close to the model when viewed in front and side view, same with ClipEnd. Then render again.

http://members.westnet.com.au/andydolphin/blender/LampClip.jpg

Once you’ve got a result, you can try adjusting the values a little to see where you’re most comfortable with it.

I know all this seems counter to the documentation which suggests everything within the start and end will shadow properly - but there you go.

wow man, u did it! thanks a lot!!

but i WHY in the world would ray shadows not work - i can’t get a shadow in this model unless i use buffered shadows and properly adjust the clip how u showed me.

…anndd i the ray shadows DO work in yafray - is it a 2.4 thing maybe?

Did you push the Ray button in the Scene (F10) panel AND the RayShadow button for the lamp(s)? (I don’t know if Yafray uses these settings - I’ve never used Yafray - but they are needed for Blender’s Ray Tracer)