Do hidden meshes and modifiers affect blender performance?

I have a huge file large maps full of terrain, many complex models, but zero animations, or active particle emitters(except for a few hairs. My blender file over time has been getting very slow. The speeds are tolerable if I am in solid mode, but pretty bad if I am in material view. Its not so bad I can’t use it, but it would be nice to improve performance so I can get stuff done faster. I have a whole bunch of stuff that is hidden. What I wanted to know is if this hidden stuff has an effect on blender performance?

if you use hide_viewport (the icons that looks like a screen in the outliner) blender won’t evaluate the hidden objects. When using the eye icon or H/Alt-H shortcut blender will evaluate geometry so your scene will stay slower.

So with hide viewport, your scene will be faster skipping hidden objects.


Thank you for the info. I didn’t realize hiding with H meant things are still evaluated. I will keep this in mind.

I’m not sure what’s going on, but this seems to not be the case in my project. I can both hide AND disable objects in viewports, yet they still cause lag unless I just delete the objects or modifiers that they use (disabling modifiers in viewport does nothing). I have some chainmail objects - source for the pattern, the actual chain main and the objects that the chainmail is binded to with Surface Deform modifier. Deleting array modifiers and surface deform modifier fixes the lag, but it’s not a solution.

Hum, bear in mind that surface deform modifier force evaluation of the target object even if it’s disabled :
object A with Sdeform has object B as target, even if you hide viewport object B, refreshing the scene cause ob B to be evaluated, you need to hide also object A.

But maybe it’s just the chainmail that is too complex. You can try to apply the array and see if that helps to get some responsivity back.

It’s a bit hard to really point to the issue without looking at the file, I’m only trying to guess here :slight_smile:
Good luck !

I actually reported the issue already here:
Disabling both objects A and B does nothing. Even disabling a composition they’re in does nothing. Also the resulting mesh data is saved with the file, even if you’re working with simple primitives with subdivs applied, the file gets huge.