do i need a material to render?

Please don’t kill me. I know this is a basic question. But it is very specific.
I only UV mapped my object. I have applied the texture.
When I render the texture doesn’t show. Everything, is… gray.
Mind you, I have not made a material or anything… never touch the stuff (its game models. in fact, in my year+ of using Blender this is my first try with rendering. All tutorials talk about materials, but these are useless for me. I don’t need them ordinarily.) The objects are just UV texture mapped.

So, is it possible to get the textures to show up in this situation when I render in Blender? If so, how?

thank you.

Well by UV mapping, all you are doing is telling Blender where to map X image, whatever it may be, onto these points of the model, but you havn’t given it an image to work with. The image you load into the UV editor is mearly a reference, like for modeling in the 3D window, that allows you to easily see where the points have to go.

Add a material and name it whatever you wish. Add a texture. In the Map Input tab, select UV. Then, in the texture buttons, load in the texture you want as an image. You can either ask, or search around if you have any other questions. There are tons of UV stuff laying around.


thanks for the reply :slight_smile:
so i HAVE to use a material? the image is applied to the object already. i can see it in the viewport. i can look at the textured object in the game engine by hitting P.

is it that the camera cannot see the texture without a material?

add a material

hit the TexFace button


where is this TexFace button? I have heard of it in legend, but never seen it in the interface.

===ah wait!. i find it … once i make the MATERIAL!

haha. :o

so… okay…
why are there two ways of applying a texture in Blender?
some historical reason? or some functional reason? (that’s probably like asking why is the grass green or the sky blue.)

but more importantly:
thx, everything renders like a charm with the material and stuff but…
How can i get my Alpha channel to render?
I’m clicking the UseAlpha button but it is not working.


Is alpha turned on in the Map To tab in the material buttons? Also, is ZTransp in the Mirror Transp tab turned on? (They both need to be in order for alpha to render.)


yes! it works. thank you Laurifer [!]

(i also had to change the blend mode to Multiply in Map To but now the alpha renders excellently.)

Err …, set DVar to 0 (and read the docs).

i dont see whats the problem for me i just create a material, dont put any settings, press [f] for face select, get the uv map, load image, map it, render.

oh and to test if it works for you just try alt z that should help.

the problem was that i never made a material before. didn’t need too because for game models it isn’t necessary. i usually just make, map, and export (never read the docs about rendering either …yesyes, i’ll get on it.)

i knew alll about alt+z and have never had any problem to see textures in the viewport. my problem was not seeing the same thing when hitting the render button. but now i know that there is no render in blender without a material attached. good to know.

this alpha thing is mysterious… with 3 different places to turn on the alpha and also now a DVar… hmmm… i’ll look it up. but that seems to do make my whole material transparent which ain’t what i want. i just want the alpha channel’d parts transparent… but anyway.

thank you all for your help.

Once you understand it, it’s simple. Till then … :wink:

So we are talking here about material transparency, not texture transparency i.e. the object itself shall become transparent.

You will make an object transparent if you set its Alpha Value to zero.

  1. The simplest thing would be to set the Alpha slider on the Material Panel in the Material Buttons to zero. If you do only this, you will see the world background through the object. Turn ZTransp (or Raytransp) on, if you want to see the objects behind the transparent object.

  2. If you want to use a texture to make an object only partially transparent, you have to have a basic understanding of the “Map To” panel. The “Map To” buttons set the value that shall be changed. So if you click on “Alpha” in the “Map To” panel, the texture will change the Alpha Value of the material. The destination value (DVar) tells you, to which Alpha value a white texture pixel will be set.

If you take a completely white texture and leave DVar on 1, the Alpha Value will be changed to 1. You won’t notice that, because the Alpha Value is already 1. If you set DVar to 0 the object will become transparent, because the Alpha Value is changed to 0.

A black texture won’t change anything. Black pixels mean “do nothing”, grey pixels are something inbetween.

So to change the Alpha value you have to use an intensity value as texture input. This is either

  • a procedural texture
  • a derived intensity value from an RGB (e.g. image) texture
  • a greyscale converted value from an RGB texture if you click “No RGB”

So how can one get a semi transparent material from a semi transparent texture? Well, a transparent texture is treated as black, that means it won’t change the Alpha Value by default. So you have to klick the Alpha Button on the “Map To” Panel twice!

And now again all settings at a glance.
How to use an image texture with partial transparency:

  • Turn “Use Alpha” on for the texture.
  • On the “Map To” panel set “Col” and “Alpha” twice. Set “DVar” to zero.
  • Turn “ZTRansp” in the “Mirror Transp” panel on.

This may be a bit strange but makes absolute sense, because many people use it just the other way round. That would be:

  • Set “Alpha” in the “Material” panel to zero.
  • Turn “Use Alpha” on for the texture.
  • On the “Map To” panel set “Col” and “Alpha” once. Leave “DVar” on one.
  • Turn “ZTRansp” in the “Mirror Transp” panel on.

Hope that helps :slight_smile:

I’ve made a tutorial: