Do transparancies work in 2.61

I’m trying to make my character’s goggles (lenses) transparent but receive specular… however, anytime my transparent alpha is above 0.0, the object becomes opaque. Also, if I leave alpha at 0.0 and take spec up anything above 0.0, the object becomes opaque.

Anyone else having this issue? I’m a bit new to Blender so maybe I’m doing it wrong but it seems fairly intuitive.

When you assign your texture (with alpha) to your material, be sure to tick the button next to Alpha here (and leave that Alpha setting to 1.000) :

Then in the Render tab, be sure to enable Transparency -> Ztransparency and set that Alpha to 0 (or near to it, see what’s giving you the better result for your googles)
(note you can try instead of Ztransparency the Raytrace setting to see if it’s better for the rendering)

And because the model even mapped with a transparent texture will cast a shadow, you can select the material of whatever is behind the model , scroll down and in the Shadow tab, enable “Recieve Transparent Shadows”

Seems like that’s exactly what I was doing. I’ll have to try again when I get to work tomorrow.

Thanks so much for all the detailed info!!! :slight_smile:

You will also have to drop that Specular, under Transparency, to 0.0 as well.

So as it stands, I can only make something completely transparent (i.e. not seen at all… as if it doesn’t exist) by turning Alpha and Spec to 0.0. Without spec or reflection, how am I suppose to make something look like glass or plastic?

This is frustrating. You would think that simply turning the Alpha of the Transparency down would make the surface less opaque. Surely this is a bug right?

What specular shader are you using ? What is your specular hardness ?

This is frustrating. You would think that simply turning the Alpha of the Transparency down would make the surface less opaque. Surely this is a bug right?
Reducing the alpha makes he material more transparent. Bug ? Usually these type of things are caused by lack of user knowledge. But what would at least be helpful would be for you to attach a screenshot are much more helpful your blend file.

I thought you were using a texture with alpha channels and wanted the alpha of it be appear transparent in render.

My bad, here’s a simple test model with a plane that act semi-transparent while getting specular from a lamp on it , like a window over another model :


testglass.blend (64.4 KB)

I made a simple test scene and it works just like you guys are saying (simply by checking transparency and adjusting the alpha), so there is something wrong with the goggles object I’m working on.

I saved it as a test scene and got rid of all the shaders on the object by going to the shader panel of the object and Xing them out. When I render, there are no shaders on the object, however, I am still seeing the texture image on the object in opengl. If I add a new shader with tranparency, it doesn’t work. I can see the diffuse color, but it doesn’t provide me with transparency.

I tried uploading the blend file here but it won’t let me… so here’s a screen grab.

Is there any way to save a blender file in ASCII so I can see what it’s referencing in script? My object seems to be referencing a material that isn’t showing up in the pane… which is most likely why I don’t see transparencies properly.

You can upload a blend there if attaching it to BA is failing.

For your problem, have you setup the other material to recieve Transparent Shadow as i mentionned in a previous post ?
In your screenshot, your render look exactly like this :

That happen if i do not enable Recieve Transparent for the half sphere and cubic thing own materials around the glass. As if i do, the render get the glass as i want it :

I am a freaking idiot!

Thank you Sanctuary. Yes… that was exactly what I was doing wrong.

I still don’t understand why I see the texture image on the object in the view panel after deleting the material off the object. That’s why I thought there was something going wrong with the software.

Now working like it should…

I think it’s because what you see in the viewport is the texture that is assigned in the UV/Image editor to the UV of something, not what is assigned in the Material->Texture .
I think you need to enable, if your card support it, GLSL instead of the default Multitexture (press N to open the panel in the right of your viewport, scroll down to “Display”, there should be a drop down menu allowing you to switch from Multitexture to GLSL) to see what is defined in Materials. in the viewports.

That has always been a rather unintuitive part of Blender since forever, puzzled me a lot originally before i figured out that what is in the UV/Image Editor takes priority over whatever you define in the material-texture tab, unless you have GLSL activated.

Ah… you are a smart smart man. Yes, that is exactly what is happening. GLSL worked just like you said.

I’m 100% sure that this is a bug now. I just can’t reproduce it accurately.

I am having the exact same issue as before where I have a transparent object that casts shadows no matter what. If I take Spec to 0, then the object is 100% transparent with no IOR or Spec (like it does not exist). I’ve checked “Receive Transparent” under Shadow for the object behind the transparency to no avail.

What’s strange is that this was working fine just a few minutes ago. Then I moved the geo and now it’s broken.

I can go back to a previous version and it works… they are identical. The forum is not allowing me to upload the .blend file. :frowning:

Here’s an example of what I’m getting… mind you, the eyeball has receive transparent shadows turned on… and even if it did not… it should not go black (it doesn’t in the previous versions of this file).

If you can’t use forum attachment due to browser settings, you can upload a blend there as it always works :

Thanks man! Here ya go…

Puzzled me a lot, until i noticed you had Ambient Occlusion turned on.

If i turned the specular to the maximum in the transparency->raytrace tab, i indeed obtained this

And so after just disabling the ambient occlusion, it became this :

Sometime it’s just a little setting somewhere that seem to break everything :wink:

(very impressive model by the way)

Thanks for the help man… I really appreciate it.