Do you know what is this effect & the shortcut to trigger it?

Hi,

I’m new to blender and i don’t know what i pressed but in my solid mode part of the mesh is now displayed in the way you can see.
How do i trigger this effect (on & off) and what is it exactly?

Has it affected the physical geometry of the mesh or is it fine and it is just the shading in the viewport? It might be you switched on smooth shading but hard to tell with a cropped shot, can’t see if anything is enabled or disabled to cause it.

Thanks for the reply,

the geometry is preserved (i attach a video), also i was messing with bones and rigging, so not shading and similar (a full screenshot won’t show anyhing of the sort at least)
i tried with the smooth shading but it doesn’t solve the problem. (also if i apply smooth shading to other parts I’m not able to replicate this effect)

https://blenderartists.org/uploads/default/original/4X/5/0/5/50555fdf352c748b5565c66b03de43d8f57d6eca.mp4 https://blenderartists.org/uploads/default/original/4X/5/0/5/50555fdf352c748b5565c66b03de43d8f57d6eca.mp4