Does anyone know why this is happening?

Heres the blend,

Start the game when you open the file. The object looks partly see through.

Recalculate outside normals in edit mode.

Thanks 3d :eyebrowlift: i appreciate it

You should tag this as solved - use Advanced Edit on your first post in this thread.

Its nothing to major, just some of the normals are facing the wrong direction, all you need to do is go into edit mode select the face select option hit n to open the property window scroll down to the tab that says ‘Mesh display’.

Then click a button under the normals option that has a face colored orange and that should show you what direction each face is facing, you might need to change the size option a bit.

Once that’s done select any faces that point inwards towards your model. after all the troublesome faces are selected hit the mesh button at the bottom of the 3d window and go up to the normals option and then click ‘Flip normals’ option and that should work, I’ll edit this post with the fixed normals in a bit

Most faces should be fixed, you might want to double check though


ufo.blend (545 KB)