Does Auto-save/Recover ever work as intended?

I’m not sure what I’m doing wrong but in my 1 year of using Blender, I’ve never had the auto-save feature ever come in clutch. I have it set to auto-save every 2 minutes but generally the last auto-save point is always 30mins to several hours away from my crash point.

Am I missing something here?

image

The feature has always worked flawlessly for me. When i switched from 3DsMax to blender a little over a year ago when i was still using Windows 10 and even now in the latest version 2.91 on Linux Fedora Workstation 33 or on Linux CentOS 8.2

After a crash there’s always a file that’s at most 2 minutes old.
Autodesk couldn’t manage to do that once in over 10 years i worked with that POS software.

What you can try:
Your settings are fine, that are the default settings.
Try changing the folder the autosaves get written to in the Preferences >> File Paths >> Temporary Files.

Check that path and see if you have enough HDD space left and that folder isn’t write protected or something. Monitor that folder with your filebrowser while you have a project in blender open and see if the files get written there.

If it doesn’t work then submit a proper bug report with all your info to the blender devs:

  • Operating System
  • Blender Version
  • Steps to reproduce

Hope this helps!

1 Like

Thank you for the suggestion. I’ve just now setup a new temp folder on a separate drive to see if that works. Before doing so, I checked what the last autosave point was and it’s from 40 minutes ago. Fingers crossed this works.

Keep in mind the information from the tooltip: sculpt and edit mode data is not saved. Perhaps that could be the reason for “too old” auto-saves. Switch modes every now and then :wink:

I’m mostly in object/pose mode and autosave is still being fickle.

image

Note it’s 12:43 local time for me so that’s 1.5 hours since the last autosave.

1 Like

Works fine for me, never lose more than couple of minutes

Looks like Xpose Picker addon is what causes issues with autosaves.

Hello,
I am aware of the issue and took action on it. This has been fixed and will be deployed by the end of the week with the update containing this and other improvements.

Also there’s a blender ticket which describes global problem:

Please update your X-Pose Picker add-on to ver. 1.9.0 after the availability notification.

Best Regards!
Albert

1 Like

Wow, this is such great news, thank you!

I was more than willing to give up on autosave because X-Pose is such an essential addon for me and I can’t imagine posing without it.

1 Like