DOF blur looks "stepped"

Hey, I have a feeling like the solution will either be really simple or none at all, but…

My DOF blur shows these ugly stepped increments. What can I do to fix it?


I’ve tried tweaking fStop, MaxBlur, Threshold, Bokeh Type. Nothing helps. Even tried adding a second blur in the pipeline.
Ideas anyone?

Assuming you are using the Defocus node with Blender Internal and the compositor, you might be seeing the pixel resolution of your output image size. One way to smooth it out is to render a larger image (say 400% larger), increase the max blur limit (perhaps twice as much), and then use a scale node (for 400% render size, set to X=.25 and Y=.25).

Thanks for suggesting.
For a still that is a good idea, but this is to be animated and boosting the size to 400% would just murder my render time.

The step width would be cut in half with 200%, but that still would take four times as long.

Can you post a .blend file, this result doesn’t look right to me.

For sure.
http://bit.ly/17qWIqY

Try enabling the Full Sample Check box: Render Properties Buttons> Anti Aliasing Tab>Full Sample Check Box. Also make sure your AA filter size is turned down to 0.5. Filter type, size, and Full Sample all matter. Quadratic filter seemed to work better in my test but this is something that you have to play with because the filter types look different based on your render size. Blender developers were kind enough to include 7 spare render buffers so that you can cycle through with J key and Alt+J key in order to determine this for yourself.

Attachments




Thanks RamboBaby!
I tweaked it a bit based on your third example and it improved considerably.

It helps sometimes to enable Limits for the camera within the viewport. Then you can see exactly where your “in-focus” point will be in your rendered output. You can increased the Distance parameter to move the target into or out of the scene.

Attachments


Also … is anyone (other than yourself …) actually going to see this artifact, sufficiently to call it “objectionable?” If the answer is “no,” then you have No Problem.™

Do an actual-size test render, put it on actual viewing equipment, stand back from the screen as far as people will actually be when they see it, and then decide if it is a “show stopper.”