Dof Dis or Dof Ob, not working?

Hey there,

Thanks for your time. I’m trying to create the depth of field effect… I’ve been using Photoshop and now I’d like to actually learn this method in Blender so it’s more authentic.

If I draw a cube, and then select my camera, I thought I could just edit the “Dof Dist:” option within the Editing menu. That didn’t seem to do anything. I then tried the “Dof Ob:” setting. I put a shape directly in front of the camera, and made it transparent. I then pointed this to that shape, hoping it would blur anything behind that shape (made it transparent in hopes of blurring things behind it, so I could actually see it).

No luck either. Any suggestions?

Thanks!:cool:

You need to use the defocus node and compositing to actually blur the render.

You need to enable ‘Do Composite’ in the Scene (F10) panel.
Then go to the Node Editor, and click enable ‘Use Nodes’ on the header.
Then click Add > Filter > Defocus on the header and a node called ‘Defocus’ should be added to the node editor.
Connect the ‘Render Layer’ node to the defocus node (click and drag from the first node’s right side yellow dot to the other node’s left side yellow dot)
Connect the defocus node and the ‘Composite’ node in the same manner.

Check out info on the defocus node settings here.

This may be another alternative for information concerning dof in Blender.