DoF, NEW VERSION, see on 4th. post! (Nodes and little tutorial included)

(eaglebreath) #1

So, I made this last night:
New version:

First time trying to use DoF and reflective floor. By the way, in that …thing, in the middle. It has no textures, or particles and that way I am very proud of it :slight_smile: I was supposed to put this to finished but thought that I can improve something before that. Can you tell me what to do next to this pic?
Other comments and critics are welcome as always!

0 Likes

(tcrazy) #2

I would put less blur so that the object is completely in focus but the backround is still blured

0 Likes

(Atom) #3

I would add a few more of the subject in the distance to add to the depth effect.

0 Likes

(eaglebreath) #4

Okay, I thought too that my blur is too agressive… What that size-button does in Map value-node? And I will but couple of those things more to the pic! They are very memory killers, though. Particles could have been better in this project.

0 Likes

(eaglebreath) #5

New version: Two objects more, changed a little bit my DeFocus-settings…

Personally I like this one much more! What about you?

0 Likes

(tcrazy) #6

I like it a lot more…what setup did you use cause I keep trying to do DOF and it doesnt work

0 Likes

(CoreyAvitar) #7

Hey I really like the way this looks. Can you explain how you made the object?
what renderer did you use? how did you light it?
(haha, death by questions)

0 Likes

(eaglebreath) #8

I try to write down the workflow of making that kind of objects :slight_smile:

  1. Add UV Sphere
    2.Now for some randomness: subdivide it 2 or three times and then press fractal( about 70 percent) and then you press rem doubles in the same panel. more you left the vertices, the more shin those “needles” will be. I used 0.300 in limit and 0.000 in threshold.
  2. Then select all vertices( A-key twice)
  3. Press E-key, select invidual faces and play it.
  4. You can make that invidual-thing again, rotate and scale, for example.

The lightning:
To tell the truth, I don’t know why, but I don’t have any lightning in this pic! no lamps, spots or anything. I don’t know is this possible but There aren’t any lights =) Anyways, objects are highly reflective, and they have no textures( they wtf, difficulties with English)

Renderer is Blender internal. I’m surprised it rendered this so good! Good old internal, hah

I’ll post the node setup after I have finished my dinner…

Edit:
Here you go:

Thanks to Marsan for basic idea of nodes.

0 Likes

(simhar) #9

why don’t you use the defocus-node for the dof???

do you know, that the defocus-node is for dof, with much better results??

S.

0 Likes

(eaglebreath) #10

No, I don’t use defocus because I don’t like the way it looks… Though I haven’t played with it so much…

0 Likes

(BlackBoe) #11

eaglebreath: You know you have to turn off ‘preview’ in the defocus node, right?

0 Likes

(simhar) #12

can you post a *.blend.

i would give it a try…

i guess, with the defocus you won’t get these artifacts on the rim of “your balls”.

oh, and you have to set the focus distance in the camera edit panel.

S.

0 Likes

(eaglebreath) #13

Yes I know that distance-thing. But i find this map value-node more useful… I don’t know where to put my blend file… tell me and i will give you a try =)

0 Likes

(tcrazy) #14

I used the same setup but it wont work when i do a normal render nothing happens and when i do a render by clicking the render button on the render layers node it reders then has a black box with a white number one in it and it stays like that and never blurs

0 Likes

(eaglebreath) #15

You have to press do composite-button on render tools

0 Likes

(CoreyAvitar) #16

No lighting? huh- cool!

0 Likes

(mattebb) #17

The problem with the z-blur-map value approach is that it’s wildly inaccurate on overlapping geometry. The top of your closest ball is blurred when it shouldn’t be, because it’s overlapping the background which is blurred. The defocus node, while not perfect, does a much better job of masking.

But to each his own :slight_smile:

0 Likes

(Guitar87) #18

Yeah, De-focus also blurs z values beyond and before your focus value, to more accurately depict real DoF. That way, you can focus on an object in the background and have the foreground blurred too, without having to set up four times as many nodes.

0 Likes

(eaglebreath) #19

Alright alright :stuck_out_tongue: I’ll try this one with defocus…

0 Likes

(Guitar87) #20

golf clap

0 Likes