DOF with Blender 2.46

I was trying out some DOF stuff with blender 2.46, using the same exact techniques as I did before(with older versions), but now for some reason, when I do it, the background is taken out and appears black. I’m not sure why it does it or how to fix it. Is there a way?

How have you done it? Perhaps if you upload an example blend it would be easier to troubleshoot.

I use nodes with camera parameters. Seems to work fine.

Could you just post an image of how you did it? That would be plenty for me to follow.

Here is the simple Defocus node setup. (Note: Camera DOF is set to focus on the object called MidGround.)

Here is the result of using the above node setup:

If it helps, here is the blend.
Defocus.blend (135 KB)

Hey Matt,

Is that a BLEND file as an attachment?
How did you do that…?

@Atom, That is part of the new overhaul on BA. When Goofster took URL posting away from new users, he added the ability for all of us to Post blends. Happy happy days!!! Just use the Attachments like you do for Jpeg or PNG files.

Hey i just did my first ever composite thanks to your blend file - happy days

I hate to bump threats but I hate creating a new threat for a small problem all the same…

Anybody have any idea how to get rid of this artifact? I want the surrounding of the photo of the guys to be blurred as well…
Please help!

By the way, I found something out, when I disable OSA it works fine. However it is really aliased naturally… Ideas?

can’t help you there as i’m only learning - but have another question -

i’ve a profile wide shot of a guy running in a field with trees in the background. I’ve put everythin onto different layers. What do i need to do in the compositer to give the feel of the guy is in the grass? As is he looks like he’s just pasted into the picture with the alpha over filter. should he be on the same layer as the grass?

Thanks! Very easy to use.

@Dundaglan: With Alpha Over nodes, the item that you connect to the top image link goes behind the item you connect to the bottom image link. Here is an example of using Alpha over with three render layers:

And the Blend:
LayerTest.blend (480 KB)

Yeh i’m kinda up to speed on that part. I just wasn’t getting the right look - so i put the field and character on same plane and composited the rest

now kinda same idea. I’m just wondering when you render images for the compositer are they flat pictures or is there still an element of ‘distance’ or depth

here’s a composite. Using alpha overlay the river is above the whole field. if i switch i dont see the river at all as its under the field

What i’m trying to get is the render below - that was done without the compositer

Can i get the rivers edge to slice into the field in the compositor or is it what you see is what you get?


@Dunaglan: You can use Z-Combine nodes instead of alpha-over. However, in my tests keep getting OSA artifacts.

For the future, if you want to use Z-Combine, turn on the Save Buffers button on the Render output panel and click FullSample. This will render the composite for FSA and get rid of the OSA artifacts.