door frame disaster, how do I make one?

trying to make a door frame from a shape, but when I try to line up the edges at 45° I make a mess, rotating the edges change the shape of the object, resizing the object back to the size I want changes the angle.
How do I line these up and make an angled intersections. Also I’m still a newb, so your patience in explaining with steps are appreciated but explaining without steps will not help me at this time. thanks!

Or you can make a profile, convert it to a curve, use a bezier circle and turn all points into a vector, define the size of your door frame and then apply the profile as the bevel object.

@JA12 found your file and tired it, I am not getting the results you got, obviously I’m missing something, so I’ll go back and try it, I think I need to be a little more familiar with Blender, still learning the interface by trial and error and modeling is not going as fast as I had hoped.

@AJM, not sure what you did. Is it possible to break it down step by step? Profile and defining are operations that I’m not familiar with, at least not with those names.

A step by step example :

Create your profile, (you can use a Curve , but it’s not necessary if you’re not confident working with them, as we can convert the profile to a curve after creation)

As -another- Object (i mean in Object mode the frame and the profile must be 2 separate object), create your window frame

Select your Profile object and go into Edit mode, select one of the vertice you want as the profile base and press SHIFT +S then select “Cursor to Selection” (or click on Mesh -> Snap -> Cursor to Selection)

Go to Object Mode and click on the Origin button then select “Origin to 3D Cursor”, so we move the origin of the Profile object to the 3D cursor.
The origin location is important for the next steps, you can test around with various locations for the origin and see what happens next to see which is giving you better result.

Now, still in Object Mode, select your profile object and press ALT+C and select “Curve from Mesh/…” (or click on Object -> Convert -> Curve from Mesh/…) so we convert that profile object into a curve
Do the same for the window frame object, convert it into a curve object too.

Select now the window frame curve object.
Go into the Curve “Object Data” panel and set it to 2D (default is 3D, but for what we do , 3D will result in something very bad, it has been reported as a bug but rejected as it being normal)
Then in the Geometry tab, at the “Bevel Object” drop down menu, select the name of your Profile curve object

Result :

You can then, with the window frame selected press ALT+C and convert it into a mesh object again

Where did I screw this up?

I think the problem is that you have rescaled the frame curve object, or the profile curve object, or both while being in Object Mode (i can see that in the N panel, above the “dimension” i can see that Z is not 1 but 4.063 , hinting about a rescale having been done in Object Mode and not having been applied.

When you do so -in Object Mode- you then need to apply your transformation (no need to do such thing if it was done in Edit Mode) by selecting the object and press CTRL+A -> Rotation&Scale (or click on Object -> Apply -> Rotation&Scale)

Not applying a rotation or rescaling you do in Object Mode usually end into very odd deformation later, depending on what you’re modelling you may sometime want such deformation, but the majority of time you don’t want such thing, and you need to apply those rotation/scaling (or do them in Edit Mode instead).

Once you have applied the rotation&scale, you’ll see in the N Panel the Scale X/Y/Z becoming 1.0

This should solve the problem.

If it does not, you should upload the blend (before you converted both objects into curves) so i can give a closer look.

I think I got it! Thanks!

I’m embarrassingly stuck on step 1 (total noob).

What should I add to create the profile? Is it surface, a mesh or something else?



The shear command can also be used to make 90 degree turns with shapes like these.

I’m almost there. I made my frame and a profile and can apply the profile with bevel, but really puzzled about what’s going on with scale/sizing

Below is what I have:

A frame of 211 x 126mm. What I’m trying to do is apply the profile to the INSIDE edge of this. I’ve no idea how blender applies the profile, so figured I’d experiment. I did “apply scale” to the frame before applying the profile.

I created the profile using extrude at actual mm values.

The profile’s only 19.5mm x 26mm, but seems have gotten a lot bigger (57mm) when applied and has increased the size of the frame the 2 x width of the profile. I can’t figure out or how to get it to apply the outside edge of the profile (left side) to the inside edge of the frame or why it’s resizing the profile. I’m sure it’s just one checkbox I’m missing :confused:

. Can anyone help?

It will all depend on where you place the origin point.
In the case you need to place it there or somewhere on that edge in the left :

Thanks a lot!

Will give it a try when I get home

Unfortunately, still can’t get it to work. The finished product got even bigger this time (29cm)

My blender file is also attached (there’s something on layer I’m not using BTW)


Profile4_BeforeMesh.blend (515 KB)

I don’t know what was going on, so i reworked the thing like this :

  • delete the “Profile” in the “Bevel Object” setting

  • converted the square back into a Mesh with ALT+C

  • converted the profile (Bezier Curve, not the very small “Profile” object you had) back into a Mesh the same way

  • moved the origin to where needed in the profile and to the center of it for the square

  • dissolved every faces into 1 in both object and press X -> Only Faces to delete the face for each object but leave the edges

  • converted back both objects into curve with ALT+C

Now if you select the square curve object and in its curve panel select the “Bezier Curve” as the bevel object it will work , the measures will be kept
I attached the blend
Still not understanding why it didn’t worked before , i thought it was a problem of scale in Object Mode, but you can’t apply scale/rotation transformation to Curve and in the N panel they didn’t seemed wrong.


Profile4_BeforeMeshfixed.blend (470 KB)

Thanks so much!

Could I trouble you to explain this bit: “dissolved every faces into 1 in both object and press X”

I think I understood the rest

Thanks again


By example, when i converted the profile curve into a mesh, here’s what i looks like :

I select all, press X then select “Dissolve faces” so it become a single face, a ngon (a face made of more than 4 vertices)

With that face selected i press X then select “Only Face” so that ngon face is deleted, but the edges around it are still there, so i can convert it back into a curve object like i want it to be

Here’s another. I used objects in the original file.
I made so many changes though that I’m not going to list them. In this case it’s more straightforward to start again than trying to fix the original.

Profile4_BeforeMesh_ja12.blend (488 KB)

Thanks a lot for the explanation. Seems I still have a LOT to learn