Double keyframes in GraphEditor.

Hi!
Like in topic, I don’t know if this is bug, or I don’t know something about Graph Editor. Clearing key frames with “O” shortcut isn’t solution, because it breaks any earlier changes into handles. Hope You can help me :slight_smile:

Cheers!

Is there a problem ?

Attach or link to blend file.

I attached image, I can’t attach file because it is from work. It just add 2 keyframes at the same frame. I figure now that only occurs when i copy paste keyframes in ActionEditor, Blender don’t merge it. Is there other merge option apart from this in view menu of action editor window?