double sided walls


(blenderage) #1

I have a plane im using for a wall, my character will walk through one side but not the other, ive selected two-side in face options but it doesn work. does anyone have a solution, apart from duplicating the plane (becasuse this will cause slow down when i duplicate my walls) and making it into a cube doesnt help. Ive also fiddled with face normals outside but no luck. Thanks for any help


(Abracsis) #2

i’m not sure i understand you fully but…

YOur character is dynamic yes? your using Force - apose to dloc ?
Your character is not travelling to fast that collisions aren’t being detected?

Occasionally a blender bug can mean things go through faces. This is due to rounding up/down of co-ordinates.
To resolve that bug keep everything inside, or close to the initial 3D grid.

hope this helped, if not, post a link to the file

-Luke


(mainman) #3

are you sure that collision is selected in the face options?


(blenderage) #4

im dloc so thats probably it, is their a way around it? because the collision is detected on one side of the face.


(saluk) #5

For true collisions you really need to use either LinV or Force. You may be able to get it to work if you scale up your world, but it’s a gamble. Dloc just isnt reliable for collisions (although force doesn’t work that well sometimes either :smiley: )