Doubt on subdivided cube vertex translation

I am new to blender but I have a doubt that id like to discuss on "subdivided, cube face,
center vertex translation view.

This is not so easy to explain but ill try my best.

Follow Steps:

Open blender, the cube should appear
Go into edit mode
Select the cube and subdivide it once
select a central vertex on any face of the cube
translate outward

rotating the object I notice that two of the translated faces are different from the other
two. Four side symmetry is lost. Should look like a “Pyramid”.
Two “L” faces and two “” faces.

Experimenting with simplest cube mesh translations and subsurfing it looks like an
interface display problem and not mesh problem.

Doubt remains though and I would like to know if it is a design bug or a design decision
by programmers to opt for different display?

I ask because this does not happen in other 3d modelling programs. See Hexagon 2. The edges are drawn as a pyramid.

Is this a bug, a limit or decided by programmers to be like that?
Does this affect in anyway the ending mesh?
Is there a command to improve view? Like with wireframe wiew in object-mode?

Cheers…

Video: Blender 2.x subdivision vs Hexagon 2.x tesselation here

Attachments




An image, maybe?

Sorry OTO was getting them ready…

Images are there now…

Weird…probably a bug?!
To solve the problem, select each “bad” face, the do Ctrl-T to “triangulate”, then select the middle edge and rotate it CW with Ctrl-E keys!
Bye

I did more experiments and yes it looks like a bug.
I solved issue selecting bad faces “L” shaped ones deleted the faces and recreated them selecting vertices and pressing f.

Reported as bug on Blender 2.5 bug tracker here

Ctrl-t then Shift-j.

Make them split and then get all Dark Crystal on their asses, and join them back together. But yeah, looks buggy, but I understand it.

If you look at it when you press ctrl-t you’ll see how the faces split. But some of them are split the other direction. Join the faces again (shift-f in case you forgot what I posted right up there. :stuck_out_tongue: ) and hit shift-ctrl-t. When you subdivide it’s cutting two squares the ctrl-t way and two others shift-ctrl-t way. I guess the only real fix would be for blender to guess how to split it as you move your verts around.

The problem is that a four-sided polygon (or any number of sides greater than 3) cannot be guaranteed to be planar, that is, all the vertices are confined to a single plane. By grabbing that one vertex and moving it, you’ve made a non-planar quad. Rendering hardware and software can either refuse to allow you to move it, or allow you to move it and do it’s best to render anyway by breaking it into triangles. Obviously, refusing to do it would be annoying, so we get an artifact such as you saw. This isn’t a bug so much as a natural consequence of non-planar polygons.

beefcalf
the image don’t show it, but two sides are displayed “correctly”!

There are two ways you can split the quad into 2 tris. Some of the quads split one way, two the other way, hence the difference. If it has to split it, blender doesn’t know how YOU want it split.

Richard

Thanks beetcalf, I understand your explanation well even though I am not an experienced 3d stuff programmer.

I tried on Hexagon 2.5 - Added a cube subdivided one face and translated it from center vertex and was correctly translated.

As I wrote at the top maybe it is not a blender bug but a programmer decision. Seems it can be done though, and it could be an improvement! Don’t you think?

I added a screencast about this problem here!!! (removed)

Between 6:00 and 6:19 what is the purpose of this procedure. You are only creating lines, not splitting the top polys so in effect it is the same as your original cube but with these additional lines which play no part when you move the centre vertex.

Richard

Yes its the same as the original cube. Wanted to reproduce same situation but didnt work right… To me it looks like subdivision is working in a strange manner though.

Tried the same thing in Cinema4D 10. The same as in Blender. As said in an earlier post, because the face isn’t planar it can split into tris in two ways. This is the diference in how the faces show up.

http://www.screencast.com/users/blenderwho/folders/Jing/media/8e17caab-2721-4351-a902-9c0c8e9c569b# (requires flash)

Richard

Thanks Richard I did see your screencast. Strange it works in hexagon though.
Is the image here showing what you mean about tris in two ways?

Attachments


That’s right.

Richard

Sorry for all of this but I’m still trying to figure things out.

When we subdivide the cube we are really getting something like “Blender Subdiv”, in the image below, but hidden. And that’s why we see the translation of vertex that way.

If we subdivide to quad and then ctrl-t to convert to tris we should get the same as “Tris 1” with visible edges and split faces. Did not work. As “Quad + ctrl-t” Image shows below.

As above but with ctrl-shift-t in 2.49b should be like “Blender Subdiv” but one gets something like “Quad + ctrl-shift-t” image. Could not try in 2.50 because they changed shortcut and haven’t found it yet.

And this should be how it is supposed to work?

Attachments



There really isn’t any bug here. Blender is operating properly, although it could do better. When you subdivide the cube, Blender displays quads. However, internally, the cube is subdivided like in your above pic under “Blender Subdiv”. Blender will always render tris regardless of how many vertices the poly has.

Blender’s subdivision algorithm is absolutely correct, but from an artistic perspective, either “Tris 1” or “Tris 2” would be the better choice. There really is no way that Blender can guess which way is best for you. The only way to correct this is by subdividing the quads into triangles yourself. Of course, you want quads and not triangles, so I can see your frustration.

I did try this in 2.5 and while the subdivided cube is rendered “wrong”, the resulting object from the subdivide modifier is correct.

Well, I suppose Blender would be better if it had a preference for making convex, rather than concave triangles, based on its normals. But that’s something better addressed in BMesh’s development.

Maspeir, no frustration at all, just a doubt that is still a bit there but, with good explanations, coming to an end. Oh yes, this has not stopped me from doing real nice stuff with blender.
I have one question for you though, do you really say blender is working correctly looking at the two images that I named “Quad + ctrl-t” and “Quad + ctrl-shift-t” Shouldn’t the first look like “Tris 1” and the second to “blender subdiv”?
Those are a consequence of a subdivision and “ctrl-t convert to tris” and one of the edges points the wrong way.