DTS Exporter Dilemma - Urgent Help

Here’s to hoping this is the right place to ask…

Okay, so I needed the DTS Exporter so I can export my models into the Torque Game Engine as part of my homework. So I installed that using the script that came with the zip file.

But then, something changed unexpectedly. Before I installed DTS Exporter, Blender could export into other kinds of files like ms3d (of Milkshape). After I installed, the Export option showed me only DTS, and the other file formats had disappeared.

Can someone please answer these questions?

  • Is this supposed to happen? If so, where can I find the other built-in supported file formats?
  • If not, how do I fix this? I’ve already tried uninstalling and reinstalling, but it still shows me the same settings and I’m afraid that installing the DTS Exporter is irreversible.

Though I might not need the other file formats soon, their absence is really bothering me, since they were there when I first installed Blender and I feel I may have changed something else for the worse.

Hope to get some answers soon and thanks.

Sounds like somehow in the installation your corrupted the .blender\scripts directory. if you delete the contents of this directory, or remove or rename it then you will experience what you have seen, Its easy to reinstall blender and try it again I guess.
For what its worth, when I was playing with Torque, a few years back, I found it easier to put things through Milkshape first but things may have got better since then.

I tried your suggestion, Larryboy, but I ended up with no scripts instead. Does that mean that version 2.47 doesn’t provide the scripts anymore? Should I go back to 2.46 or is that even still available?

Well I just had a go and instead of using the installer script I copied all the files into the Scripts directory and all seems fine. I don’t have Torque installed anymore but all the exporter options are there including torque.

I would suggest you uninstall your copy of 2.47. Make sure all the files are deleted in the install directory. reinstall a fresh copy, and then copy the DTS exporter files to the .blender\scripts directory… it should work :slight_smile:

I tried that too, but I still didn’t get the old scripts back. But it’s okay now. I got a friend to install a fresh copy on his computer and send me the scripts from there. And I installed the DTS exporter manually like you suggested.

Thanks again for your help, Larryboy.