Dual bevel mode proposal.

I’d like to propose bringing the old bevel behaviour back as an alternate “mode” for the bevel tool. Whilst the old behaviour is not as good for actual bevelling, it was a great tool for adding extra geometry and smoothing out models. It made for a fantastic alternative to sub-d modelling. If you are unsure of what I’m talking about, please follow the link and watch this video by Chris Kuhn:

So the proposal is simple. Press Ctrl+b to enter bevel mode as usual, then hit “B” again to invoke the old behaviour.

As you can no doubt see from the video, this functionality is extremely useful and needs to return. I assume this is a trivial task as the code already exists in older versions of blender.


Moved from “Latest News” to “Blender and CG Discussions”

Whoops. This is where I intended to put it in the first place. Sorry about the flub.

If I understand correctly, to not overlap the edges, you just have to press C when you create the Bevel.
You have options at the header.

It isn’t just a case of not overlapping the faces. The distribution of newly created faces is completely different from the old bevel tool. Watch that video again, and you’ll notice that this type of bevelling is essentially doing the same thing as adding a subsurf modifier, without the disadvantages associated with using subsurf on hard surface models.

This is one function I’ve hoped a lot that existed in Blender, because I have had problems with bevel tool because the overlapping thing in multiple areas of modeling. And now I know it existed. :s You can add proposal of it to here and someone will read it https://rightclickselect.com/p/

You can post here :wink:


Doesn’t changing the Bevel mode to “percent” make it work pretty much exactly like the old version of Blender?

For me actually it does. I usually forget to check that tool panel when using some tool, because the panel is (for me) very unintuitive place and most of time it is scrolled off so it is not even visible.

How do you use it? Selecting an edgeloop, bevelling, then switching to percent does nothing at all.

you need to increase the width substantially. when you switch to percent, try inputing 15 or even more.

In case of parallel edges I won’t do anything because both methods produce the same results, however with very unaligned edges you can see an obvious difference (similar to switching between “even” on/off when sliding an edge). Current bevel definitely has drawbacks though but they are being investigated currently as far as I know !

Change the mode while beveling using “M” and turn on clamp overlap using “C” and then just adjust the bevel using the mouse. There should be a huge difference to the default mode.

Granted it still doesn’t seem to work exactly like the old behavior but it’s pretty close.