Dual Monitor in Ubuntu

Hey guys. I recently installed Ubuntu onto my computer. The problem is, I’m having a really hard time setting up my dual monitor display. I’d love to get it similar to the dual-view display that is capable in Windows using a Nvidia graphics card. Any help would be awesome!


Well I don’t know others milage on this one but for me I have been using dual monitors on Linux for the last 3 or 4 years and I still end up editing the xorg.conf file manually to get it to work when ever I change distro.

I use 2x 21" Iiyama Vision Master Pro’s @ 2560x1024

This is my /etc/X11/xorg.conf.

/etc/X11/xorg.conf (xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

(Type “man /etc/X11/xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg


If you have edited this file but would like it to be automatically updated

again, run the following command:

sudo dpkg-reconfigure -phigh xserver-xorg

Section “Files”
Fontpath “/usr/share/X11/fonts/misc”
Fontpath “/usr/share/X11/fonts/cyrillic”
Fontpath “/usr/share/X11/fonts/100dpi/:unscaled”
Fontpath “/usr/share/X11/fonts/75dpi/:unscaled”
Fontpath “/usr/share/X11/fonts/Type1”
Fontpath “/usr/share/X11/fonts/100dpi”
Fontpath “/usr/share/X11/fonts/75dpi”
# path to defoma fonts
Fontpath “/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType”

Section “Module”
Load “i2c”
Load “bitmap”
Load “ddc”
Load “extmod”
Load “freetype”
Load “glx”
Load “int10”
# Load “type1”
Load “vbe”

Section “InputDevice”
Identifier “Generic Keyboard”
Driver “kbd”
Option “CoreKeyboard”
Option “XkbRules” “xorg”
Option “XkbModel” “pc105”
Option “XkbLayout” “gb”

Section “InputDevice”
Identifier “Configured Mouse”
Driver “mouse”
Option “CorePointer”
Option “Device” “/dev/input/mice”
Option “Protocol” “ExplorerPS/2”
Option “ZAxisMapping” “4 5”
Option “Emulate3Buttons” “true”

Section “InputDevice”
Driver “wacom”
Identifier “stylus”
Option “Device” “/dev/input/wacom”
Option “Type” “stylus”
Option “USB” “on”# USB ONLY
Option “Mode” “Absolute”# other option: “Relative”
Option “Vendor” “WACOM”
Option “TopX” “180”
Option “TopY” “130”
Option “BottomX” “10028”
Option “BottomY” “7294”

Section “Device”
Identifier “NVIDIA”
Driver “nvidia”
Busid “PCI:5:0:0”
Option “RenderAccel” “true”
Option “NvAGP” “1”
Option “NoLogo” “True”

Section “Monitor”
Identifier “Generic Monitor”
Horizsync 85-100
Vertrefresh 50-120
Option “DPMS”

Section “Screen”
Identifier “Default Screen”
Device “NVIDIA”
Monitor “Generic Monitor”
Defaultdepth 24
Option “TwinView” “true”
Option “SecondMonitorHorizSync” “85-100”
Option “SecondMonitorVertRefresh” “50-120”
Option “MetaModes” “1280x1024, 1280x1024; 2560x1024”
Option “TwinViewOrientation” “LeftOf”


Section “ServerLayout”
Identifier “Default Layout”
screen “Default Screen”
Inputdevice “Generic Keyboard”
Inputdevice “Configured Mouse”

Section “DRI”
Mode 0666

Ensure you have the NVidia proprietary drivers nvidia-glx-new or nvidia-glx-envy first.

I’m using a PCIx NVidia 7300GT as I’m not a gamer and broke.

Running glxgears isn’t that inspiring btw, 2215 fps anyone getting much more with dual screen?

You can have a GUI if you want it.

open a console.

step 1: sudo apt-get install nvidia-settings
step 2: nvidia-settings