duplication has color missing from duplicated parts?

I paid a blender user to build me this helmet. I’ve decided I want to elongate the bottom portion of it. Not knowing how to do this, I have tried to duplicated the bottom row of faces in edit mode and then attach them to the bottom of the helmet. As tedious as this is, I can kind of do it, except for the problem you will see in the attached pics.

The yellow box indicates what I used to duplicate and the red lines point to the areas of color that mysteriously disappeared on the duplicated material. anyone know why this is happening? Why is it not a solid color like it is on the helmet?

Also, is there an easier way to do this? Am I making things harder for myself than what they are?

thanks



Well maybe that user should fix it for you at no extra charge…

The issue you have is that the faces you created are not connected to the rest of the helmet and are also marked as smooth (or might have a subdivision modifier) so they tend to show as curved. You need to select the vertices at the edges of the new faces and merge them to the vertices of the old geometry.

But it might be a lot easier to delete what you just did, select the rings of vertices at the very bottom of the helmet and pull them down on the Z axis, and subdivide later…

thanks for the response.
it’s not the creator’s fault. he did just as I asked. When I composited it over my head on a video, I realized the short comings, which is my fault.

I tried various things but could not get the vertices of the new edges to merge with the old geometry. Would you be able to tell me how?

I have no problem deleting what i did in the picture and starting over as it only takes a few seconds to select and duplicate. I don’t know what the rings of the vertices are, but I selected the bottom of the helmet and stretched it downward. Unfortunately however, when rendered, you can see the stretched area even over the texture and materials. looks really unnatural.