Dupliverts > Rot


(SimonHK) #1

Hi gang,
When parenting a cube to a sphere and setting dupliverts on I get what you’d expect.
When setting the “Rot” button to get all the dupliverts to point according to the normals of the sphere, I get distorted cubes, not cubes that point in the right direction. The function doesn’t seem to work properly, am I doing something wrong or is it busted?

SimonHK


(SirDude) #2

It works fine for me. What version of blender
are you using? I tried it with linux2.23

Also make sure your cubes are small enough that they are not overlapping. (Maybe your just getting confused with whats what)
If your still having problems post a blend
we can download and look at)


(IamInnocent) #3

The coordinate systems of your child and parent object probably got out of alignment in respect of one to the other. You can verify that fact by selecting each one in pink and setting the “axis” button in the edit buttons (far left, down) and see if all axis point in the same direction in both objects. Then you’ll just have to rotate the child the right amount so both systems align.

Hope this is clear.


(SimonHK) #4

thanks jean, boths axes are aligned…
It seems to be about non-proportional scaling.
If I scale the child object on a single axis, it all goes out of wack.
X, Y and Z scale all have to be the same for the dupliverts to be the correct shape.
Editing the size and shape in edit mode works fine…so I guess thats the answer…

cheers…

SimonHK


(ilac) #5

You can always use ctrl A to apply size and rotation from the object to the mesh.

And don’t forget Alt R, Alt S, Alt G, to remove rotation, scaling and location respectively. from the object.

Regards
Fabrizio


(IamInnocent) #6

On 2002-03-25 03:33, ilac wrote:
You can always use ctrl A to apply size and rotation from the object to the mesh.

Fabrizio got there before me but ctrl+a will be the solution for your problem.

Learned some more, again, answering you.