Dvorak Keymap (for 2.5)

When I switched to Dvorak keyboard layout several months ago, I begun to have problems with using blender. I kept pressing the buttons I remembered, although most of them represent another letter than before. There are several solutions:

  • Re-learn the new key positions
    I don’t think it would be a good idea. Not only it would take a long time, but the keys are placed ergonomically for a QWERTY keyboard and now would be mixed up randomly.
  • Switch system keyboard layout when using blender
    I tried that, but it is pretty uncomfortable. A bigger problem is that I have switched the buttons physically too, so trying to recall a key position on a QWERTY keyboard was often quite hard.
  • Remap internal blender layout
    And here we go.
    >> Download <<
    edit 2010-11-29: updated for Blender 2.55

It should be installed easily: in User Settings > Input, click the Import Key Configuration button below.

If the file does not work with your blender version, or you would like to translate some other layout (your own or the Maya default), you may try to generate it directly. I wrote an addon with a single operator: Export Dvorak Key Configuration. If it works, it just asks for a file name and saves the altered configuration to it.
Download it here.

I have not used the layout much yet. Maybe the globally used shortcuts should not be converted, so that Ctrl-S stays Ctrl-S. I am getting quite used to the position of such common ones by using other applications. Tell me what you think.

I just tried using this, but it doesn’t seem to work. I clicked on import key configuration and after selecting the file it went back to the input settings with no indication of success or failure, but none of the keymap’s have changed.

That’s right, I wrote the piece of code in May and Blender has changed a lot since then. I stopped using this layout myself, but as you reminded me now - wait a minute, I’ll generate it again.

Still doesn’t seem to do anything, it doesn’t help that Blender doesn’t give any feedback at all either. The shortcuts are still not changing.

OK, the entire input thing in Blender seems to be complete nonsense, I tried exporting key configuration and then importing it again, and that doesn’t even work.

Trying to add a new layout, I click the plus button and it asks me for a name. After entering it, the only thing it’s added to the list of presets is ‘Add interaction preset’, which is obviously not the name I entered, and it won’t let me change it. Nothing about these input settings make sense.

It also seems to be losing my key config after a reboot, despite having saved as default. It worked between quitting and starting the program, just seems to have forgotten it now that I’ve rebooted.

Well, blender does not give feedback when a keymap is successfully loaded, but it simply works for me. (I press O > scale, I > grab etc.)

I use blender from SVN, and I just checked that this keymap won’t be accepted by Beta 2.54. There seems to be a bug, as beta cannot even export its keymap correctly. To get this working, you’ll perhaps have to get blender from graphicall.

Thanks for that, that works. Curiously the SVN build needed another dependency in order to run, perhaps that had something to do with it. Is there any way to remap the shortcuts to constrain transformations to x,y,z? Z being on the opposite side of the keyboard is a bit of a pain to reach, couldn’t find them in the shortcuts at all though.

Unfortunately, these seem to be hard-coded.
It makes some sense: they are no hotkeys, just character input. You cannot remap them; similarly, you cannot remap position of numbers on the keyboard.

But the Z is really hard to reach and I guess most QWERTY users would like to have better access to their Y too. I wrote an idea to Blenderstorm, let’s see what others think.
I hope the server is still active, it seems to have lost user interest in the last weeks.

They’ve finally fixed the 64 bit 2.55 version, just installed it on my laptop. It looks like they’ve tweaked the keymap stuff again, think you can take a look?

Dreamsorcerer:: I haven’t used blender for several weeks, so I tend to forget about this. Thanks. I updated the link, you can try if it works correctly.

Nope, that doesn’t seem to be working, after applying it, (QWERTY) G still runs insert frame, but the old translate shortcut doesn’t work, so it must be changing some but not others. Looking in the “Transform Modal Map” section, it says the translate shortcut hasn’t changed.

Yeah, I didn’t notice modal maps didn’t get translated at all. Try again.
And I finally wrote a generator script simpler to use (hehe - wrote… I mostly copied Export keyconfig operator), link is in my first post too.

Keymap still doesn’t seem to be working. How do I run the script? I’ve added it to the plugins and enabled it with the checkbox, then what?

To use that addon, just run the operator, called Export Dvorak Key Configuration. I didn’t make any interface, because I guess everybody needs to use the operator at most once.
But I’m afraid that if you can’t load the key configuration itself, the addon will work no better.

What problems occur when importing the keyconfig file now? Does it load partially or not at all?

Right, factory settings, (QWERTY) U runs translate, G runs insert keyframe. After importing keymap, U runs Make Single User, G runs nothing. Scale still seems to be on the old position, so I’m guessing the main transform tools are not being changed.

Looking in input, under “Transform Modal Map”, the keys don’t seem to have changed.

OK, so the transform modal map is not the shortcuts I thought they were. The ones for transform tools, selection tools etc. are under 3D View > 3D View (Global). And none of the shortcuts under this section have been changed by the keymap.

I tried changing these manually, but then I find that there are further problems, such as the specials menu is on the right shortcut in 3D view, but when you tab into edit mode the same key now changes pivot point to bounding box centers, specials being on the old shortcut.

Any update for Blender 2.6?
I get the following error with the current script:
http://overshoot.tv/ticket/1156#comment-572