Dxf arhitecture file partially visible on blender

Hi all,
I know more people already faced similar problems importing Dxf/Dwg files, but about this one I really haven’t found any solutions:

I need to import a an AutoCAD architectural plan on Blender to make the 3D model with textures, materials and so on.

Then I used a converter for Mac, created an Dxf version, activated the add-ons for dxf files, set the metric units on the software and increase around 100km the maximum visibility.
The result, is the architectural plan of a scyscraper floor whose only some lines appear, and aren’t not even the most important ones (not section walls, no doors, neither windows…).

What’s worse, if I try to import the .svg format of the same file, Blender has a never ending loading (even 10 minutes).
Any ideas? Did someone face the same situations?

It’s probably a very dumb problem, but it has been stopping me by hours and I don’t really know how to proceed.

To give more info:
-The converter program is ODA, and I exported in 2018 ASCII DXF and 2013 ASCII DXF.
-The Blender version is the 2.79, and when I activated the add-ons they had (and still have) an yellow alert icon.
-The Blender importing settings for .dxf in a screen


Thank you everyone.
Gio

when you export try to unblock all the objects in CAD file
easier to import to Blender
also the addon DXF is a simple one
also there is a better DXF import by Mignus
but it is a paid one

any idea on the size of your file for import
or how many verts ?
some file can be in Gbytes so blender will take along time to complete the import

happy bl

Hi,
I don`t have AutoCAD on my computer, so I cannot change the format from the original model.

I don’t know what might be causing this, but I do have AutoCAD and would be happy to try to import in Blender for you if you could send me the file.

Thanks Filipe, but as work project I’m not even supposed to put it on my private laptop (wrote badly on the former message: don#t have AutoCAD on my company computer).

Yeah, I imagined this could be the case.

In any case, what I usually do that works for me 100% of the time is to use the 2004 DXF and import into Blender 2.79b with de default settings. Sometimes when something is missing from the view in strange ways it’s due to the scale. I simply press the A key to select all and scale to 0.01 to help fit the view better, then I do a zoom extend ("." on the numpad). Later on I can adjust to the right scale. Doing some inspection in the outliner may also help point out if things are really missing or you just can’t see them.

See if this post can help:

Also, for conversion to dxf i find Teigha converter set to 2004 ascii dxf format ok. Upon import, an obligatory scale down to 0.01, just as @flimabotelho advised, with converting the output curve to 2D and no fill in the properties panel.

Try Rhino trial version, iirc 30 free to test, consider buying the program if you want to seriously do archviz.
Good luck!

@Gio.A - if you don’t already have it, get DWG TrueView from Autodesk. Handy not just for viewing DWG files but also converting to earlier formats. It doesn’t convert vertical content such as ACA (which may be part of your problem) though. Also have a look for the Autodesk FBX Converter utility - I’ve found it useful when walking content through multiple formats.