DXF export size issues?

Can somebody help me figure out how to get my scaling right. Exported as .dxf and what was .1 in blender turned out to be .00254 in my other program. How can I model and export the same size? I had to scale by 39.3864 in the other program to get the size right. The only way I know is model to size and then scale by 39.3864 in blender before export. Is there a way to not have to scale after ,but export the same size as what the dimensions says.

  1. Is your object scale applied? (That is, does the object you’re exporting have uniform unit scale?)
  2. Judging by the number it “turns out” in that other program, there seems to be a unit issue. Like, the .1 to .00254 seems like the other program thinks that it’s importing inches, and converts them to meters.

Normally exporters have scale adjustment during export, however the dxf exporter does not have it, it seems. It is possible that the unit type is misrepresented in the dxf file.

As a temporary work around, just create an empty with 39.3864 scale. Model as you wish and prior to export make the empty the parent of your mesh using the object properties pane. Then unparent it after the export to get your original scale back.

You can even set an object constraint for it so it is easier to enable and disable this. There could be more workarounds like scripting it.


Yeah, object scale applied and other program is set to inches.

I think the dxf exporter is exporting as meters. Looks like I will have to do your work around until a scale option in dxf exporter.

OK, it prolly exports as units set to none. I noticed it has the same number.

Units set to metric(meters) and number is .00254

Units set to imperial(inches) and number is .1

What other software are you exporting it too?