DXF import broken?

I knew that there are problems with DXF import but had no idea that it won’t work even with very simple files.

Here’s my DXF file imported into 3ds Max 5:

And here’s the same file imported into Blender:

I’m new to Blender so I’m not sure but… is this importer totally broken or I’m missing something here?

If Blender’s dxf importer comes up short, a good converter is Accutrans. Reads almost any dxf and converts it to an lwo or obj that Blender reads without any problems. Very inexpensive, and imports and converts many 3d formats.
http://www.micromouse.ca/

I tried to use another converter 3D Object Converter which is free and looks pretty impressive (supports lots of formats) but it failed. The problem is my DXF file isn’t a 3D mesh of any sort - it’s just a line (a KML file to be exact). So I guess Accutrans would give me the same result.

Never guess - test, and confirm. Have you actually downloaded Accutrans and opened the file in it? Don’t forget: the “trial” version is the full version of Accutrans. The author trusts its users to pay for the inexpensive license after a month’s use if you decide to keep it.