Dynamic spacebar menu 2.8

add-ons

(Meta-Androcto) #1

hi, I’ve updated the dynamic spacebar menu addon for 2.8
It still needs some work before adding back to Blender. Feel free to test.
new hotkey is Alt/Spacebar
space_view3d_spacebar_menu.py (125.9 KB)


List of addons that work with 2.8
(wolfmanyoda) #2

Fantastic, thank you.


(bkjernisted) #3

I have this error and it will not show up to enable it. There is another older copy in addons. Do I replace it with the new one? I had put the new one in addons_external not knowing there was one in addons already.


(Meta-Androcto) #4

yes you need to replace the old file with the new.


(saunam) #5

Thank you Meta-Androcto.

By the way, why did you change the default hotkey? I thougt the reason for existing of this addon was to replace Blender’s default spacebar use.


(Meta-Androcto) #6

Re: keymap change.
hi, I had issues with Blender start up and the new spacebar options. The addon only worked under certain circumstance. As the Spacebar has more configurable options in 2.8 I considered it a no longer valid key to overwrite. When this script was first designed it was to bridge the gap between 2.49 and 2.5 when the old spacebar menu’s were abandoned by Blender and the spacebar used as search. The idea was to make it easier for users to make the transition from 2.4x to 2.5x. As the Spacebar now has multi options for the user to consider, including some menus, I thought to change the hotkey to alt/spacebar to avoid conflicts.
I could be wrong here and created another conflict… Time will tell :slight_smile:


(mediaklan) #7

Ah ! One of my favorite addon back again ! Thank you meta-androcto !


(NewVisitor) #8

Great!
Thank you very much meta-androcto.


(bkjernisted) #9

Alt/Spacebar will not bring up the menu for me. Anybody else have this problem? Thanks…edit…I tried it on my laptop and it would not work either. It will not work with “run as administrator” either. Just wondering if my anti-virus could stop this from working?..edit…Is the keymapping built into the download or does it need to be set up in blender?..edit…what do I need to do different in the picture?


(Spirou4D) #10

Wonderful thks Meta-Androcto…At soon and Happy New Year 2019.


(rombout) #11

Sweet!!! I love this thing so much :slight_smile:


(rombout) #12

Ill change alt + space back to space. I like that better :slight_smile:

edit
just read your post on why this change was done. What issue did arise?


(Meta-Androcto) #13

I found that it was not working and space just playing animation. maybe something to do with the first start up screen where you choose which function you want the spacebar to hold. I will try again with a new build. In around a week I’ll make final decisions and put the addon back in Blender official addons where it belongs.
I’m gathering feedback here and need to double check my fixes and incorporate the new object types.

Currently missing is:
Light probe object type, I would like to fix this before releasing in Blender.
Grease Pencil I removed, I doubt I’ll re do the grease pencil modes, that should be an addon in itself. It’s a far more advance entity now. I’ll need to tidy up the code here.
Pivot point entries are also gone. I’ll probably bring them back at some stage. They were broken and probably easier written as a macro.
The Texture paint brush drawing was also broken with Internal Icon issues. They will be brought back at a later stage in redevelopment.

The change of Hotkey was caused by some conflict I got when I set the initial spacebar options. I will look into it further before making a decision either way. I don’t mind the new hotkey but it breaks with a long standing tradition…


(bkjernisted) #14

Does anybody know why it is not working on either of my computer’s? I have tried numerous things. I have tried it on 7 builds. Please read my post 8 or 9 above. Thanks… Problem found…I had to enable 3dview:

dynamic context menu


(mak485) #15

alt+space_bar may conflict with pc/laptop os default keymap.
for my ubunntu 18.04, i disable this keymap from system, now working fine for me.


(rombout) #16

Perhaps make that part Cursor, never understood why it said “Snap Cursor” while it actually show much more settings.

PS what was broken with Pivot menu or options than? I never noticed that it didnt work properly

Also snapping is simplified now, it only shows snapping on/off, the other options dont show