Dynamic Topology Crashing Blender

Okay, so I’ve been a somewhat active (Not very good) Blender Artist for quite some time, and decided to take it up a notch and started getting into some longer, more difficult tutorials from Blender Cookie. First, I downloaded the Introduction to character modelling series by Jonathan Williamson and got a ways into it until the sculpting part. I’ve never been good at sculpting. At the time, I was using Windows XP Home Edition SP3 and Dynamic Topology worked great. I sculpted and sculpted for hours until I finally got frustrated and took a “Blender Break.” Some time in between then and now I decided to upgrade to Windows 7, and Dynamic Topology worked fine on that! But then I decided, hey, why not Windows 8.1, so I upgraded.

After a couple of weeks I decided I wanted to try out the Creating Piero series by Kent Trammell just for the learning experience, so I fired up Blender 2.69 and jumped into the first few videos. Just 5 minutes in, I was told to enable Dynamic Topology so, of course, I did. Without any warning, Blender just closed like I had hit the little, red, Develish X at the top right. I didn’t even get a crash report. I just said, “Well that sucks,” and fired up Blender again, having dealt with crashes and data loss in the past, and recreated the scene. I saved and enabled Dynamic Topology again, and boom, crash. I tested to make sure it wasn’t just the version, but with every single version since 2.66 It would close it. I’m not sure if this is just my system which is pretty noobeh for what I’d like to do with it, or if I just need to tweak something.

System Specs:
OS: Windows 8.1 32-bit
Intel® Pentium® Dual CPU E2160 @ 1.80GHz
Ram: 3317 MB
Video Adapter: Intel G31/G33 Chipset (256MB Memory Type 2)- Integrated Graphics 0
Hard Drive: 320GB Hitachi + Seagate Backup Plus 1TB External Hard Drive

Any help would be appreciated. Thanks!

I remember that the devs mentionned that Dynamic Topology use VBO (even if you have it OFF in the file -> user prefs -> system), i’m not sure the g31/g33 supports them with the default driver, so you could try to update your video card driver in case it’s related, as it’s possible when you upgraded to window 8 it installed older drivers, while you had newer ones with XP or 7 that were more compatible with VBO and so Dyntopo .

I had this problem with an old computer, I think that the integrated graphics were too old (After I got it a graphics card, it worked fine). However, by what you’re saying you’ve upgraded your computer from XP to 7 to 8. Many old drivers work well in 7 but horribly in 8.
I once upgraded an XP computer to Windows 8, and it was very unreliable when using blender. However, after I downgraded it to Windows 7, it worked fine.

Try upgrading the graphics card driver.

Ah, yep, there are no graphics card updates available for my old drivers for Windows 8… Guess I won’t be doing any Blending any time soon ._.