E-Cycles 2021 - 2.92 available with very fast rendered viewport, real time light setup and more!

Hi @chafouin ,

only sobol and dithered sobol support light groups officially for now. Most scenes render faster with samples halved and AI-Denoiser than with adaptive sampling and AI-Denoiser anyway. This is mostly due to the fact that AIs are trained on sobol and that adaptive sampling is only speeding-up rendering when the scene complexity is very variable across the frame. As NLM is nearly not used anymore, I mostly test builds with sobol (activating adaptive sampling silently switch to PMJ).

On top of that, light groups are most of the time useful in the lightning setup phase only, which can now be done in the viewport (and where adaptive sampling is not available). When you are done with your light setup, you can apply the strength and tint and use adaptive sampling. So the priority to make both compatible is currently low.

If it really helps in a production scenario and is superior to other available techniques, I’m ok to investigate. Could you please provide such a case (per message/PM if you want)?

1 Like

E-Cycles 2.91 beta is available with:

  • fast light groups creation + real time tint and strength adjustment
  • persistent data
  • viewport light groups
  • native support for RTX 3xxx GPUs

You are welcome to report any bug you find to get a polished version for your workflow :slight_smile:

Happy rendering!

4 Likes

Hi Mathieu,

Find a ‘’.blend’’ file where you will see the problem with E-Cycles and Pro Lighting Studio:

E-Cycles_Bug.blend (226.5 KB)

Thank you,

I have to say that the viewport light groups is pretty amazing… This is a genius workflow.

2 Likes

Hello @bliblubli

Im using 3 months membership for E - cycles …
and I received a RTX 3080 today

my test BMW scene

Blender CUDA 0:27
Blender OPTIX 0:12

E-cycles CUDA 0:13
E-cycles Optix 0:08

how many improve E-cycles RTX ???

sorry for my bad english

Thank you :slight_smile: you doing amazing work :slight_smile:

1 Like

@bliblubli, thanks for getting back to me. I have another question about blender 2.91 version you just uploaded. I am trying to activate my optix in Cycles, but I keep running into this error when I select viewport:Optix

I turn off blender, and restart but the error comes back.
I am using NVidia Driver 452.06 and using a 1080Ti. Any ideas???

I had to do it :yum:

Multicore CPU VS GPU E-Cycles persistent data.

2 Likes

thanks for the file, I’ll have a look to it asap!

Hello @Culdos ,

You’re welcome, thanks for the benchmark of the 3080! They look really good. The BMW render times with E-Cycles are now so low, that export time and precision issues can become significant. I would recommend rendering it at 100% to better see the actual speed-up.

Regarding E-Cycles RTX, the speed increase is around 2x with RTX cards on average against around 1.4x most of the time with E-Cycles standard + OptiX.

1 Like

Hi @Vesper ,
recent versions of E-Cycles require Driver 456+. I send an email to everyone, but as usual, it seems the rate at which it is really delivered is rather low :confused: I think I’ll make important announcement on the splash screen later to ensure you get up to date with latest development :slight_smile:

1 Like

Made with E-Cycles last week:





Two interior renders made by artists I really like with E-Cycles.

Hey Man, I hope the time off goes well for you, I am not sure if you are completely off btw. I downloaded and installed the latest drivers, and I just downloaded the latest 2.92, I am still getting the error even with the latest errors for cuda…

just to reiterate I am using a 1080 ti and the driver I am using is 456.71

Hi @vesper,
I just tested with a 1080Ti on latest E-Cycles 2.92 and 2.91 on both standard and RTX, with CUDA and OptiX and couldn’t reproduce the issue. I used driver 456.43 on Windows 10. I would try to reset factory settings. Sometime drivers are not updated properly too on Windows. Using the DDU to clean those up may help.

You can get E-Cycles with 30% off on the Blender Market during the support pause!

1 Like

I noticed in Cycles discussion thread that tile stealing from CPU in the end of CPU+GPU render has been implemented to Cycles. Hopefully this will be added to E-Cycles as well, as I’d be interested to see how it affects render time. Currently GPU only rendering is faster in my cases, but this could make large renders little bit faster.

Link to Cycles commit:

2 Likes

Hi Mathieu,

Did you get a chance to take a look of my file?

Thank you,

Would be great to have one tile size for cpu and another for gpu in cycles.
With same tilesize i cant use the multicore cpu its to slow.
And with newer gpus its even a bigger tile gap cpu/gpu.

1 Like

I guess this will have to come from the official release at some point. There’s a similar discussion on the official Cycles Development thread now. I also suggested such a thing back in May '19 on RCS.

It seems as if Cycles might get a little more love now. Maybe this one gets picked up as well. Maybe go to RCS and upvote the suggestion. Who knows - it might help.

Hi,
it should be fixed in the new builds as of today. For fast bug fixing, the best thing is to contact me through official channels like the messaging system on the Blender Market or answering any mail from Gumroad about E-Cycles.