E-Cycles 2021 - Professional Render engine, 100% compatible with Cycles

It does not work. The behaviour is scene independent. Just the default scene with a cube and a plane. Cycles render device: optix

System: win10 with 2x1080ti/ I9-7940x CPU/ Nvidia
DRV 436.15

See here:

Which driver did you use?

Thanks for the report, it should be fixed in E-Cycles 2.90 v20200424.

Thanks for testing more. Again, it’s working for me and you are the only one reporting this behaviour. Can you try with today’s builds and factory settings reseted to defaults? Does it work in stable 2.82a for you?

E_cycles_2.82a_v20200312_win and resetting to defaults doesnt fixed it.
Now the rendering didn´t even start at all…

I will try a clean driver reinstallation now (436.15 again)

1 Like

E-Cycles 2.90 builds have been updated on Gumroad and the Blender Market (25% off).

  1. There are 2 new very fast profiles:
  • AO: as the name says, renders with AO. It’s the fastest one and actually real time in the viewport, vidéos coming soon.
  • Clay: renders like if your scene was made of clay, with lights and HDR to render with shadows. Still extremly fast, perfect for setting up the lightning and inspect modeling details.
  1. A lot of polishing work was done:
  • SSS is working again properly with CUDA
  • adaptive sampling is now much faster with OptiX
  • normal nodes and IES lights are also working again in 2.90.

Known bugs in current builds: Debian 9 is not working currently. Debian 10 and all other tested distros work.

E-Cycles 2.82a is very stable and still has no known bugs since over a month!

I’m working on new experiments too like fast caustics:

Made with E-Cycles this week:

  • A nice swimming pool with Susanne:
  • An impressive viewport rendering session by @johannes.wilde with very complexe lightning (very small opening, lots of reflections, etc.) using the latest E-Cycles 2.90 optimizations

Again @Luan3dr doing awesome renders:

Someone even tried E-Cycles on an old laptop with a GT 930MX and got impressive results:

And @EntityDesigner has made a gorgeous interior ( available on the Blender Market if you want):

I hear a lot of feedback of people telling me they were very sceptical first, then very impressed. Ridley was one of the most sceptical, yet here is his final thought:

Some hours left to get E-Cycles with 25% off during the Blender Market sales.

6 Likes

Since I bought E-Cycles 12 days ago Im still waiting for Linux 2.82a version to work. This is starting to be not funny. :expressionless:

It’s in the known bug: Debian 9 is not working and as said, a fix is under way.

Ok, I will wait. But consider that before buying I informed you about my OS, and you did not mentioned that Debian 9 and E-Cycles wont work.

Because you are the first one to report it. I think 2 weeks to fix a bug is still ok in covid time, even more when it requires to make a complete new build system for a single user, which I’m doing, but as I said, I’m also ok to refund you if you want.

Edit: actually, I double checked, I know about this bug with a proper bug report since not even a week.

1 Like

There is no need for a refund.

Lets stop this:

I understand about COVID-19 situation. And I assume it. Perhaps 15 days is a normal period of days to solve a bug. I dont know.

If you have to develop an environment just for fix the Debian 9 error and just for me, please stop. I understand its time and resources consumming for just one user.

I will try to use other versions (hope some one work in Debian 9). If not, I will have to migrate to Windows.

Issue end. No more bad feedback abot E-Cycles. I will try to find a solution with other versions or Os´s.

Thanks.

2 Likes

I dont know what more can i do solve this.
I reinstalled the graphics driver 436.15 but nothing changed. I choosed clean new install.
I also deleted/renamed the custom settings under:
C:\Users\xyz\AppData\Roaming\Blender Foundation\Blender

-Sometimes E_cycles_2.82a_v20200312_win shows “cancel” in the viewport sometimes nothing visible happends but blender needs to be restarted to work on.
-E_cycles_2.90_v20200421_win and E_cycles_2.90_v20200424_win are still just showing the washed out full white phenomenon.

If there is something more i can do, please let me know.

BTW: Standard rendering works flawless

1 Like

Now that I spend 2 days on it :slight_smile: And I’m happy to make my users happy. So I’ll continue this fight against Linux libs hell.
PS: If you can easily switch to Debian 10 or something else, I’m still ok :wink:

I would need an access to your computer to say what to do ideally. But I also had a hard time to get NVLink working last week so this may help:
Even clean install of the driver was not showing SLI in the control panel for me. The bios, etc. everything was ok. The internet is full of such reports, but rarely have a solution. The only thing that helped was to completly clean the driver in safe mode with DDU. I downloaded it, unpacked on desktop, pressed F8 on startup to start windows in safe mode, started DDU, selected “GPU”, “clean and reboot”, then rebooted in normal mode and installed the 436.15 driver in custom mode without geforce experience. Now everything works like a charm. Otherwise, NVidia has a chat too.

No problem. I’ve encounter this during my everyday routine work. Please try to make it work also in v2.83 builds, since 2.9 builds are more or less experimental :wink:

A render by JLE Studios with E-Cycles and with Photogrametry. Their work is really impressive:

4 Likes

Ok, the denoise viewport feature is a nice to have one but not that important for my worklflow and it looks like its very experimental atm. At least on GTX.
I will check on a different workstation nxt week.

Does it work better with the RTX 2080ti?

1 Like

Actually, in the current state, appart from undo and simulation nodes, 2.90 is pretty much like 2.83. So I think it’s good to use 2.90 as it has all the 2.83 fixes too.

v 2.83 and 2.9 will be separate options from blender for a quite good time it’s good to keep them both covered :wink:

1 Like

I’m using it daily on the 2080Ti, so yes, as other users reported it works very well. Just to be sure, I just tested on a computer with a 1080Ti and the latest 445 driver and I can reproduce your issue! I’ll investigate further.

1 Like