E-Cycles - 2x faster, 100% compatible with Cycles

New builds of E-Cycles 2.91 alphas are available!

If you like historical reconstructions and/or gorgeous nebulaes, I recommend to watch some of those animations rendered with E-Cycles:

Good day,
Is there a reset for the light groups? So that when playing with a scene, lights can be changed and the denoising info be changed.
Thanks.
Robert

Good day Robert,

You can apply the light group settings. It will automatically use the AI-Denoiser if the denoise option was ticked in your light groups panel. If you are looking for a solution to quickly set all strength to 1 and colors to pure white, there is no button for that yet. Is that what you are looking for?

Kind regards,
Mathieu

No. Mine is the ‘bad user’ need: As I have played with the lightgroups, I keep forgetting to go into nodes to work with them. To that end, I get a light group node that has multiple entries of the same or different groups I may have gone through.
That is to say, it gets ugly.
I would like to be able to reset the light node group to the collections I have now; I want the old one destroyed and a new one built, not appended to.
(Type enough and I can figure out how to say it. lol)
Robert

As I look at the interface, I want a regen on the light groups.

I think I see better what you want and what the issue is, but I think an image / GIF of what is happening in your file and what you want would help a lot.

You are welcome to send a PM or better a message on the platform you are on (“message” button on the E-Cycles product page on the Blender Market or simply answering any mail from Gumroad about E-Cycles).

We can then see if it’s a tweak to the sync/apply button or complete new operator which is needed.

Mathieu

Not sure if possible, but would be great to get a scene ready for E-Cycles so we can compare for real the speed differences.
Honestly I have failed hard on making E-Cycles to be as fast as is promoted or even close to it, so I know that is a settings things. That’s why having a scene provided by the developer would help a lot.

hi @bliblubli , I’m having some more eCycles issues that I don’t quite understand. I was working on a scene and the first 3 renders went perfectly fine. The 4th render crashes with the following error.

“Error: Illegal address in cuMemFree(mem.device_pointer) (device_cuda_impl.cpp:1035)Illegal address in cuMemFree(mem.device_pointer) (device_cuda_impl.cpp:1035)Illegal address in cuMemsetD8((CUdeviceptr)mem.device_pointer, 0, mem.memory_size()) (device_cuda_impl.cpp:1120)CUDA_ERROR_ILLEGAL_ADDRESS in cuMemcpyHtoDAsync(d_wtile_ptr, &wtile, sizeof(wtile), cuda_stream[thread_index]) (device_optix.cpp:800)”

Nothing changed in this scene except for different poses in the characters. I then opened up the same file in vanilla Blender and was able to render it without issues 4 times in a row. Attempted it 4 times again in eCycles resulting in 3 of these same cuMemFree errors and once in a crash to desktop.

The only thing different between Vanilla and eCycles settings was that Acceleration Structure Master Skin Tint was on. I attempted an additional 5th test render with Master Skin Tint off and also failed another cuMemFree error. I also uninstalled my Nvidia drivers with DDU and updated to driver version 456 as you recommended in this thread and it still resulted in the same error.

Both eCycles and Vanilla Blender are version 2.91. I’ve noticed this happening in the past as well where a scene renders fine but eventually starts crashing after the first few renders. Any ideas what the issue could be?

Thank you

Good morning (o;

Got some scenes from Entity Designer from blendermarket where OptiX rendering is not possible, saying:

OptiX backend does not support ‘Ambient Occlusion’ and ‘Bevel’ shader nodes yet

Seems this drawback exists since a year now…

Is there anything I can do to be able to render it with OptiX?

thanks in advance
richard

Hi,
thanks for the proposition. The BMW scene, which is part of the official Blender benchmarks works very well and has tons of data to compare to. If you have a file where the render speed is not as promoted, you are welcome to make a report (answer any email from Gumroad about E-Cycles or message me on the Blender Market product page)

Hi Domiek,
thanks for the report. I guess you are on Windows and you have the driver timeout still on and low? If you did set your TDR as shown in the video tutorial or use Linux/Mac and still have the issue, you are welcome to provide a file to reproduce (see email above to report).

1 Like

Hi Richard,

deleting the nodes is enough most of the time. In the rainy day scene (which is the only one with those nodes as far as I know) it’s on the skirting behind the sofa.
Otherwise, I have some beta code for supporting both with OptiX, it will take some time still to get it as fast as I want and stable.

Kind regards,
Mathieu

Heh, I have just discovered this add-on:

But E-Cycles is so fast that I guess it makes this add-on useless. :wink:

1 Like

Hi @bliblubli, thanks for the reply.

I have good and bad news. The good news is that I solved the issue and it doesn’t seem to be the fault of eCycles. One of my cards is acting up and removing it has allowed me to render without the error crash. The bad news is… one of my cards is acting up :cold_sweat:

I’m not sure why it still rendered in vanilla cycles without issue. Maybe your optimizations push the cards harder?

Either way, thank you for your help despite my numerous posts!

Hey Mat, I downloaded the latest 2.91 alpha…I couldn’t find the Mesh to volume modifier in there, is that something that was forgotten or is just a result of timing? The Modifier I am speaking about more specifically is the Volume > Mesh and not the Mesh > Volume.

They are modifiers belonging to the new volume object (which can be found in the add menu).

Create a volume object and look in the modifier context.

Do light groups work fine with adaptive sampling in E-Cycles?