E-Cycles - Fast Professional rendering, E-Cycles X available!

Hi @Flsh,
thanks for the report. E-Cycles 7 for now only focus on speed and is in alpha. Ray tracing nodes including AO are known to be broken currently. For the full feature set and maximum stability, I recommend to use E-Cycles RTX 2.93.

E-Cycles 2.93 compared to 2.92 has:

  • a way better denoiser with SSAA now available for final render
  • a new grain slider and also a much easier to use UI (basically, if your file already uses denoising in Blender, you just have to open it in E-Cycles and benefit of the improvements out of the box now!):
  • a portal generator:
  • passes denoising, including denoising of light groups passes, which is very powerfull
  • a lot of polishing and new improvements to make your workflow always faster.

I can’t find a way to upload a file, unless I’m missing something:

Anyway, it’s really any basic file created in vanilla blender with a displacement map node. If you open it back in E-Cycles 7 you’ll notice the node off.

E-Cycles 7


Thanks for the report. I can reproduce the error if the scene uses old “static” displacement indeed. With experimental kernel and adaptive subdivision it works as expected in the mean time if you want.

For attaching files, I would recommend asking the BlenderMarket here. You can also give a link to a drive, dropbox, filemail, etc. which is more appropriate for 3D files which are often bigger than 5MB.

Both the old and adaptive method are being replaced with more modern techniques using about a 10th of the memory required currently and also speeding-up the export process dramatically.

New builds of E-Cycles are available with the new asset browser!

Some renders made with E-cycles recently:


Thank you, Mathieu

By experimental kernel do you mean this?

If that’s the case, I use it from time to time when some object has a particular relevance in the scene. For simple materials, a bit of traditional displacement in general is more than enough.

Unless you mean something different, in which case I would be really curious to hear about.


Hello, I was wondering what I am doing wrong. I have 2.93 CUDA version and when I try to render any scene, it comes out half-transparent(?).

Here how it is with -Composite- layer:

I can play with light groups here which is nice

And when I change the layer to -View Layer-, it is no more transparent looking quite alright:

But then, I can not play with light groups anymore. Also, it was crashing in the middle of the rendering and when I change it to -1x SSAA- from -4x SSAA- it seems like it is not crashing anymore. I am also attaching the AI Denoise settings in case I am doing something wrong there


edit: I think I am doing something definitely wrong, I just turned on AI Denoise & Sync Light Groups. Is it normal to have such a difference between View Layer & Composite?

Thanks a lot! ^^

With experimental kernel, I mean what is in your screenshot yes, but you alos need to turn adaptive subdiv in the modifier and set you material to use displacement iirc.

thanks for the report. The half transparency issue is fixed in E-Cycles 2.93.1. It may require to deactivate/reactivate the AI-Denoiser in existing files.
For the crash, SSAA 4x takes 4x the memory to store each pass and you activated denoise all passes, so if you have a lot of pass, you need a lot of memory. Running out of memory on host (system memory) or GPU can lead to crashes. If you still have memory available and it crashes, I would need a .blend file and the information from the “steps for bug reports.txt” file (available in your downloads). You can then open a ticket on https://blendermarket.com/products/e-cycles by clicking on “Ask a question” in the right panel or by answering your Gumroad purchase confirmation mail.
Regarding light groups, it is normal that your combined pass look different from the composite output as when using light groups in the compositor, it uses the strength and tint you defined per light group pass, while the combined pass takes all passes as if they had strength 1.0 and tint pure white. If you mean something else, I would need a .blend file to reproduce as explained above.

You can now get E-Cycles 2.93.1 builds with following improvements:

  • fixed an issue with transparency when using OptiX with E-Cycles AI-Denoiser
  • optimized rendering speed with SSAA at low samples
  • the improvements from upstream Blender 2.93.1!

Happy rendering!

Artwork made with E-Cycles recently


Virtual Tour of modern great room by Dominik Koutny

Lumpy space thingies by Brent Patterson

Modern apartment by Petra Trebjesanin

Hi Mathieu,
I just downloaded the 2.93.1 because of the semi transparent render when using AI denoise, but unfortunately the problem is still there, even with a new scene from scratch

Thanks a lot for your reply. I had one other quick(?) question regarding light groups. Why am I having this many in the compositor while I have much less in the scene? Many of them are duplicates. Is there a way to refresh the light groups? I tried to delete them manually and sync again, but the result was the same.

Hi Bernardo,
thanks for the report. Can you please check it’s not just the mix node in the compositor? If not, I would need a .blend file to reproduce as the default file works for me and all the my regression test scenes.

thanks for the report. There is indeed a bug with reference counting in Blender 2.93, which leads to such issues sometime when updating the collections. I’m trying to find a workaround to this core issue as I have little hope that it get fixed with around 1500 open bugs currently. Just in case it’s something else than the other report I got, can you please provide a .blend file on BM or Gumroad (you can see PDF documentation for the steps to folloz on the platfrom you are on).

1 Like

hi Mathieu,

Thanks for the answer. You are right, it is just the mix node. The noisy render layer output is empty, and for some reason mix node adds that weird semi transparency to the render. It’s good to know, so now it’s easy to fix. However maybe it could be good to remove the mix node at the moment?

To reproduce the problem I think it’s quite easy, as for me it’s enough to render the default cube with the AI denoiser activated. I hope I am not the only one with this issue?

1 Like

Thank you for your prompt responses, I really appreciate it. I am going to provide the blend file later today, but I was just wondering if there is any manual way to refresh that list as I cannot control light groups anymore

Hi Bernardo,
that issue is fixed in 2.93.1 actually as far as my tests go. As said in the update mail, it may require to deactivate/reactivate the AI-Denoiser (you can simply clicking the main panel checkbox twice) in existing scenes to update the compositor node tree. I just double checked and it works in all the files I tested, you may just have saved a default file with the old node tree?

1 Like

You’re welcome. Normally, you can apply (if you don’t want to keep the values you have set, you can set everything back to 1.0 strength and 1,1,1 color before applying) and then resync, but I would have to check on a file showing the issue to be sure. It may require to save and reload the file before resyncing the light groups to flush the junk collections Blender 2.93 produces. I’ll try and report asap.

that’s weird… maybe I’ve downloaded the wrong version? :smiley: I’ll check it out

Or I uploaded the wrong one :wink: Anyway, at least with a compositor window opened and 2 clicks on the panel checkbox, it should work :slight_smile:

1 Like