E-Cycles - Faster CUDA rendering and better AI denoising

commercial
(mib2berlin) #892

Hi, no single (Lowend) GTX 760 but I fixed all issues with performance copying preset settings to Linux. Not all settings are reachable on Linux atm. but I am not in hurry.
I know you are a speed fan but may you remember a patch to add some wait states to the GPU to don´t block your system completely during render?
I cant find it yet at developer.blender.org.
I can render in Octane and surf the internet with some limitations without slow down render time. May a few % less.
It would be nice to have a switch for it, may GPU load High/Low or something.

Thank you for the support and for E-Cycles, mib

1 Like
(mathieu) #893

At least on windows, the experience is smooth connecting. What I do is to connect my screen to the iGPU to have the discrete GPU completely free for rendering. But I’ll have a look to this switch. If you find the exact differential number, it would be helpful to get it faster.

(CosasM) #894

Is the cpu rendering faster with E-Cycles?

(duketogo) #895

E CYCLE only works with GPU

(rafbr) #897

New benchmark single GPU:
As you can see here E-Cycles is about 25% faster but a lot noisier

(TiborNyers_BC) #898

I have reproduced the interior rendering demonstration that @bliblubli already posted a few times, but this time without screen recording overhead - 720p, 100 spp, 0.02 scrambling distance —> 5 sec render time with 2080Ti

1 Like
(DDB) #899

texture and object data already cached in vram right ?

what is the result for a similar noise nevel of cycles 2.8 official

(mathieu) #900

Hi,
I’m on it. You provided the file 13 hours ago, I do my best. It can even take some days to get fixed. Look at this bug for example which affects many archviz scenes https://developer.blender.org/T54486. reported more than a year ago, still no fix although the BF has many devs and now very good funding. You found a scene which has problem, I’m sorry for that, but I think it’s normal to give some time to people to react. Did you ever made a bug report to Microsoft or Autodesk?
If I can’t fix it in a reasonable time, I refund you. But I used to bug fixing, most bugs I got reported got fixed in a day or two. Look here for a bug report and here for the solution and here what the same customer who experienced bugs says. A bit of patience please :slight_smile:

2 Likes
(mathieu) #901

So I did several test and couldn’t reproduce your noise bug. I used both the march version and the latest beta, both render with the same noise level. The noise is different (normal as E-Cycles uses a new sampler), but not higher:
Master takes 80 secs to do the path tracing and outputs this image (time is written on the line "time without synchronisation):

E-Cycles only 39sec and output this image(AI Denoiser):

This is the noisy image:

Did you use the exact same file?
Did you use the latest beta (I added a new one yesterday during the sales, maybe you got an old beta?)

(PaulStormblader) #902

I’m someone who occasionally does long renders, and am interested in this project - curious about how compatible / comparable it is to this:

https://remingtongraphics.net/tools/d-noise/

Thanks!

(mathieu) #903

Hi,
here, an E-Cycles user did a comparison:


you have to download the images and zoom at 100% to see the difference.

Kind regards,
Mat

(rafbr) #904

Yes same file.
I am downloading beta again just to be sure.

(mathieu) #905

Hi Tibor,
Thanks a lot for showing the true speed of E-Cycles with external recording :slight_smile: I should get such a setup too. But the slowdown of live screen recording helps some to believe.
5 seconds for archviz :slight_smile:

1 Like
(PaulStormblader) #906

so you’re using the intel denoiser? Does it still work with the nvidia denoiser?

(mathieu) #907

I’m using the Intel denoiser indeed. It should work with the NVidia denoiser of course. Addons compatibility is the same as for official Blender.

(DDB) #908

about that, any news from a viewport denoiser ? both from stefan and brett?
i talked about stefan on twitter about cpu viewport denoising + gpu calculation he’s saying its possible

(mib2berlin) #909

Hi, Brecht has answered at https://devtalk.blender.org/
The patch is https://developer.blender.org/D2862
He was not very enthusiastic about the patch but was working fine with my GTX 560Ti and GTX 760 on Linux.
May you have a look, is not that big.

Cheers, mib

1 Like
(mathieu) #910

Thanks for the link :slight_smile: I’ll look asap.

(mathieu) #911

It’s on my huge todo list. Somehow, the more things I implement from my todo, the bigger the todo list is :smiley:

1 Like
(DDB) #912

ahahah same problem here, i think the third of the forum have a to-do list problem
could we know whats in the near future of your to-do list ?

1 Like