E-Cycles - The fastest render engine for Blender. 3.2 release available now!

AFAIK, For the Ambient Occlusion node, you can use CUDA. This seems a limitation of Blender OptiX, not just E-Cycles.

1 Like

Hi Hyesung,

On Cycles that true. Optix or Optix denoiser cancel the render. However all is correct with CUDA.

In other way, on eCycles2.83.6, the AO node render with CUDA is completely black in GPU (and correct in CPU)

And with eCycles 2.91.0alpha, render is black in GPU and CPU.

I’m on Win10.

And you’re 100% sure that it happens on E-Cycles and not E-Cycles RTX?

1 Like

Hi, thanks for the report. As @blndrusr pointed out, you can use E-Cycles standard. It is made for CUDA and will render scenes with AO nodes correctly on top of being faster as it has special optimizations for CUDA.

E-Cycles + RTX 3090 + Persistent Data = 3 seconds/frame (2 seconds pure path tracing)


You can get E-Cycles with 50% off on the Blender Market until the 15th of October.


Thank you. I havent try it because my graphic cards are RTX but you are right : AO nodes and True Water 4 are compatible with eCycles standard.

1 Like

I have a question about e-cycles Nebulae, and what it entails.
Is it a general volumetrics optimization, or does it only work on specific types of volumetrics?
Does it affect the speed/quality of volumes bouncing light onto solid geometry?
Does it do anything different to scenes with no volumetrics, when compared to ‘vanilla’ Cycles?


  1. E-Cycles Nebulae Edition only works for the specific type of volumetric that Nebulae are. E-Cycles standard has the general volumetric optimizations and support the full feature set.
  2. Solid geometry is not supported officially in the nebulae build.
  3. Yes, it will render most things full black, but it will render those really fast :smiley:

To sum it up, if you need fast volumes with the full Cycles feature set, I recommend to take E-Cycles standard :slight_smile:

I already have (very) wip versions of E-Cycles RTX with AO and bevel node support.


How does e-cycles works with animations? It has some sort of temporal denoising or it uses the already implemented solutions?

Not sure if I’m doing something wrong or if the Quick Settings presets are buggy.

Clicking Medium preset does nothing.

Unless I hit Very Fast preset and then hit Medium afterwards

Selecting High Quality or Physically Correct doesn’t seem to do anything regardless of which order I click.


I can’t seem to find any documentation on this. What is the “default” setting? I only ask this because I’ve never touched any of the performance settings and was just using ecycles with the default settings out of the box. However on certain scenes, depending on lighting, I’ve seen some serious artifacts and am trying to figure out a higher setting that will remove them.

Thank you

Edit: This is on the latest 2.91 RTX build

Hi, some Quick settings change only settings in Light Path.
Medium change Caustic settings but getting back to fast it does not disable it, so @bliblubli should take a look.
I checked on latest 2.91 Cuda.
If you still find issues reply to a mail from him.
Here are the default settings:


Ooops, AO is 0, cheers mib

I just purchased E-Cycles with relatively modest expectations on speed improvement to standard Cycles, as I need to use Cuda version due to shader bevels in my assets. Had an idea that could get 50-100% speed improvement, but my first tests resulted way slower render times than Cycles. :flushed:

Talking about big slow down, about half speed for same quality. Either I don’t understand something, which is the reason to post here in case someone has an idea how to fix it right away, or it just doesn’t work with my scenes. I tried different presets without any better luck and also RTX version with shader Bevels removed, but that wasn’t blazingly fast either. Below is description of scenes and I admit I haven’t started to tweak individual settings yet, as would think with presets the speed increase should be expected instead of slower render times than standard Cycles.

Scene Info

  • Scenes are “photo” studio setups with either fully matt backdrop or matt backdrop with reflective ground.
  • Assets are photorealistic products, like watches
  • Shaders are Principled BSDF
  • Lights are mainly geometry lights with texture and color temperature to control illumination.

Render info

  • Test image size: 3000x3000px
  • Cycles Sampling: 512 (Needs higher for final renders)
  • Bucket size: 128px
  • Cuda
  • GPU only (CPU disabled in settings)
  • No post process denoising used in Cycles


  • Windows 10
  • GPU: RTX 2080 8gb
  • E-Cycles Blender version: 2.83.6

Is E-Cycles only good for architectural type of scenes with some extremely specific optimizations or is there still hope for me to get it work faster than Cycles, which is the target?

Hi, I get mostly 80-100% faster render with E-Cycles, open a .blend, change nothing > F12.
May you can upload an example .blend or/and send a mail in reply of a mail from @bliblubli with attached .blend.
The only thing I don´t use are textured mesh lights.

Cheers, mib


Hmm… I’ve been using E-Cycles for over a year and it’s never been slow compared to the vanilla Blender. (It’s always fast on its own without any other adjustments.)
It would be more helpful to share the .blend file.


Sure, I’ll prepare a scene to share. Just need to re-create similar setup, as can’t provide the same 3D model and light setup as in my original test scene due to being non-public material.

I did a test with Teapot model with my simplest backdrop and basic light setup and got similar result as in production render setup test. To achieve same level of noise E-Cycles needs double the samples compared to Cycles which is weird as product description stated that it could have cleaner result with same sample count. Attached is an image of this test and teapot diameter is little less than 1m to understand the scene scale. Render resolution: 1500x1500px. (Rendered frame is 32, but not animated scene)

I will have to test more, but it might be that E-Cycles is not that efficient with geometry lights and causes more noise (textured emission shader planes to illuminate). My test with just spotlights turned the result other way around and E-Cycles was faster and noise level with same sample values were closer to each other.

Also in my renders I use quite some render passes, which I tested if would affect anything. Seems that E-Cycles slows down more with additional renderpasses than Cycles. There was no single render pass to cause slowdown, but each added pass increased render time a bit.

Here are renderpass tests with Teapot scene as I tried to check if there is a problem. I tested this with spotlights instead of geomety lights, so it is not the same light setup as in attached image.

Standard Cycles renderpasses with spotlight setup (teapot):

  1. No passes: 1:10.2

  2. Diffuse+Glossy+Transmission+Normal+Z-Depth+ObjIndex+Emission+Shadow+AO+Cryptomatte(Obj&Mat): 1:28.8

E-Cycles renderpasses with spotlight setup (teapot):

  1. No passes: 42.8s

  2. Diffuse+Glossy (Dir&InDir): 49.5s

  3. Diffuse+Glossy+Normal+Z-Depth: 51.1s

  4. Diffuse+Glossy+Transmission+Normal+Z-Depth+ObjIndex: 54.5s

  5. Diffuse+Glossy+Transmission+Normal+Z-Depth+ObjIndex+Emission+Shadow: 57.7s

  6. Diffuse+Glossy+Transmission+Normal+Z-Depth+ObjIndex+Emission+Shadow+AO: 1:02.9

  7. Diffuse+Glossy+Transmission+Normal+Z-Depth+ObjIndex+Emission+Shadow+AO+Cryptomatte(Obj&Mat): 1:04.0

%50 down the price… it means some 37.5 $? Just asking for being sure.

E-Cycles with animations just works like Cycles. If you want to denoise animations, you can either use the offline NLM animation denoiser or lower the clamping/up the sample count if you want to use any of the AI Denoiser.