easyEmit update for Blender 2.78

Hi,
for Blender 2.78x extract the “easyEmit_267.zip” file.

Edit the file “emitter.py” file and change all lines fromlogic.frequency
# to
logic.skippedTicks

and

file “init.py” the linebpy.context.object.game.sensors[‘Always’].frequency = 0

to

bpy.context.object.game.sensors[‘Always’].tick_skip = 0

That it. Zip the archive and install it again into the Blender AddOn’s, chapter Game Engine.

A tested file for Blender 2.78 is available here, from my page: http://www.wipn.de/blenderproject/easyEmit_2.78.zip

1 Like

Thanks. It works perfectly in Blender 2.78c. I have not tried it out with 2.79 because I have not switched completely over to that version yet.

I have a problem with scene.particles or something like that

Hi Nemescraft,

That is exactly the problem. The tool only works correctly if there is only one scene. If you have several scenes, the tool EasyEmit does not work. I looked at the code. In general, all particles and all other actions are always expected or written in scene 0. So if you have more than one scene, EasyEmit always tries to work in scene 0. So I changed the code. Here in the link you will find an update. But this is a quick hack. I will only be able to make a complete overhaul in the next few weeks. I like this tool for the BGE and I find no better so far. Therefore, better support should be provided. I hope the author will report this here.

It works perfect with Blender 2.79. But it may be that newer versions of Blender do not work. At the moment there is a lot of change in the Blender API. Therefore, the author would have to constantly redraw the EasyEmit system, but this does not occur.

Download: “EasyEmit Multy Scene quick hack” For Blender 2.79

Download the archiv. Rename the old directory to easyEmit_old and expand the archiv to the existing directory “addons” in Blender or UPBGE.
Standard path for EasyEmit:
C:\Users<userdir>\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\easyEmit

How to use it, include multy scene environment:

  1. Start Blender/UPBGE
    1.1 Switch Blender to Blender Game mode.
    1.1.1 Switch Blender from Multimaterial to GLSL.
    IMPORTANT: Game Mode setting and GLSL setting must be switch for all new scenes in Blender. Not in UPBGE.
    1.2 Select the default cube, if not selected.
    1.3 Open page Particle System from EasyEmit!
    1.4 !!! Important !!! press the small button “Restore Building Presets” at fist.

1.5 Now press Button Create Particle System.
2. Start Game for a simple test.

Multy scene environment:
1.0 - 1.4: Follow the steps.
2. Create all scenes
3. Insert all the objects in the scenes you need.
4. Create the particle system only in scene 0.
5. In scene 0, go to layer 19, where EasyEmit stores the ressources.
6. Select all object in this layer.
7. Make a copy in all other scenes as a link, with the following command: Object, Make Links, Object to Scene, Scene1
8. Go to scene 1
9. Select the object for the particle system.
10. Go to the EasyEmit particle system.
11. Press button Create Particle System.
12. Start Game with P. It works…

With this workaround you can use this addon also for all other scenes.

To change a particle or change the particle list, you can make changes only in the properties of the object. The EasyEmit Particle System window does not work in other scenes. For example, to start a fire in the second scene 2, the property particlelist must be changed in the properties of the object. You simply edit Particle_Fire. Here you can also enter other particles that are present in the scene 0, in level 19.

Peter

OK, will look at it!

Link doesn’t work

1 Like

The link is not working. 404 Error ?

image

the same. ;(