Edge beveling on flat surfaces without marking seam?

Hi,

Well…beveling edges of an hole in a flat object, inset the flat surface, then marking seam and then edge bevel works, but do we really have to mark edge seam for this each time? is there a bevel mystery or option I have missed that doesn´t require edge marking the seam and that would allow me to bevel the selected edges right away.

Nevermind, I got it working…just the bevel controls that are a bit wonky and doesn´t start to kick in when you adjust it…not until a certain level is reached.

What the heck…now it isn´t working again…

I did undo to all the changes, and tried again, not working…maybe mark seem was necessary in the first place for at least some edges in order for it to work?

No, marking seams is not necessary for beveling at all.

Yes, I sort of figured that, but somehow…it doesn´t work when I try the beveling again, the beveling tool seems unpredictable.

I mean, I got i working, but only after I did mark seem, and then on the other holes, I tried without mark seem, and it worked, then I did undo on all that, and tried without mark seem, beveling edges are simply not working.

Feels like something is overlooked here, seems like many people run in to this issue as well.

Could you please share that specific file? From the screenshot I can’t see why it wouldn’t bevel.

I´m about to…just preparing it.

Here´s two files
one without inset and one with.
No material is assigned, if that matters?

Edge bevel test 1_inset.blend (743.8 KB) Edge bevel test 1.blend (722.8 KB)

Blender 2.83

In both files, those edges are split so there is simply nothing to bevel. You need to merge vertices by distance first :slight_smile:

1 Like

Wonky, I didn´t do that but still got it to work, so I am just curious why.

Could have thought of that as well, since when I ported the object to lightwave, before using rounder on the edges, you have to merge the vertices.

Just need to find out what I did that actually merged the vertices anyway, without me doing it?? :slight_smile:

It´s working by merging the vertices though.
Thanks.

Just awesome finding …I didn´t know that when adding curves, on top of other curves in edit mode, it creates holes and meshes it in preview sort of, that´s great, something I can´t do in Lightwave.
so that is what these test holes come from, without having to boolean brush them, and they are all interactive none destructive when I want to edit the secondary curves/hole shapes.

Maybe you accidentally hit a key. In default keymap, the Y key splits the borders of current selection.

Yes, maybe…I messed a bit with decimate planar and extruding, something must have happened there.

I made new samples and extra careful of what I used, and it worked nicely, without even inset faces.

And oh, what I said about adding curves that makes holes in the other curves and mesh preview it, you have to add profil curves, not the standard curves it seems.
Will have to record that on youtube.

Yes, it’s a feature of 2D curves. I.e. you need to set curve shape to 2D and enable fill.

Yes thanks, Only got profile curves to work previously, but this is what I looked for as well…working nicely so great, thanks Stan_Pancakes, will have to check svg shapes, curves as well from inkscape.

You’re welcome :slight_smile:

And yes,
importing inkscape shapes or paths works as well for drilling holes directly in to another curve shape, you just have to join them since they are two seperate curve objects, and you have to set each objects cycling correct first.

There´s another tip I would like to share regarding inkscape, if you draw floorplan shapes and use stroke to path, then drill in inkscape with difference to create door openings etch, if you were to export that to svg, it may cause screwed up scaling on certain segment door openings, if you have more than one door opening.

There are a couple of workarounds to this…

  • To avoid that you can either export to pdf, and it will be flattened properly and work nicely …if using the Ai, pdf, svg importer that is.
  • Or import as svg curves only and not the ai, pdf, svg importer.
  • You can also use break up in inkscape and that will correct it.
  • you can also make sure you popout the paths from a layer, and then use path/union then save out to svg, then the ai, pdf, svg importer in blender should have correct scaling.

But I have to start another thread about that, and I really need to record that.

1 Like

Well it seems more than a complete program what is he trying to do ?!

Hmm…this is your first post ever?
Not sure what you are asking about? the task was to bevel edges…but there was some mistake done along the way that probably prevented edges to get beveled correctly, all that is solved now, so…no problems.

So what is your question here? about that? or the last post I posted, which is a bit confusing and of topic for the actual thread topic, In that last post I just touched on possibilities to add svg shapes and mix with other curves and have them drill directly in to the main shape curves from blender, and I also touched on some other issues I found could be problematic if you do inkscape booleans on paths and imports that to blender, I have no problem with that…I just wanted to highligh that since there is certain routines you have to follow to get that right.