edge render, edges go right through movie texture with alpha channel

I don’t think theres an easy fix for this but if anyone knows of any fixes it would be much 2d truck test.blend (893 KB) the edges for the cartoon look I’m going for, I attach the .blend file

sorry I meant to say appreciate somehow that got replaced with my .blend file oh well

Put pirate plane on separate render layer and uncheck Edge for this layer. Composite both layers.

hey thanks, a lot, btw I really like those cactuses you added, nice touch