Edge Ring Select does not work for me

I cannot seem to get the Edge Ring Select to work. In fact I cannot get any of these loop selects to work using the hotkeys. I checked the preferences to see if I am using the correct keys and I am.

For Edge Ring Select, it is set to use Mouse, Ctrl + Alt+ Select Mouse. I switched my mouse select to left mouse. So, in edge mode I tried to collect an edge first, place the mouse cursor over the next edge and then hit Ctrl + Alt + Select the next edge with left mouse button. Nothing happens. I then try to hit Ctrl + Alt + Select an edge before selecting an edge first to see if this would work; and it did not work.

Does anyone know what would cause a keyboard hotkey not to work if you use the combo that is in the preferences? I am using the default preferences except for a couple hotkeys I added. But, others are using these same hotkeys and have no issues.

I am using Blender 2.62.

Any help would be appreciated. Thanks.

It’s likely there is a conflict; Ctrl+Alt+Select is already in use. Look for “edge ring select” under ‘Input’ in User Preferences

I will check this after work tonight.

I think I already found that it is set to edge ring select and nothing else. I did not manually change this. I even tried the factory settings and did not get it to work. I must be doing something wrong; but what?

I will double check after work.


What OS are you on? I had some issues with Linux Ubuntu/Mint. Found the solution somewhere in this forum. Though at the moment I cannot pull it up.

hotzst: I am using WinXP Pro service pack 3.

I checked the link that you gave and cannot find where the settings that was explained are found.

I did find the following: in Blenders preferences, under input > 3D View > 3D View Global > something called “Activate/Select” is set to Ctrl + Alt + Select Mouse. So is Shift + Alt + Select Mouse and so is Shift + Ctrl + Alt + Select Mouse.

Do these settings have anything to do with the reason I cannot do an edge ring select?

These are the factory settings. First things first: Can you select an edge in edit mode with your mouse button (RMB if you have reset your setup to factory settings) but without any mod-keys? Then CTRL-ALT+RMB and ALT-RMB should toggle between edge ring an edge loop selection. Perhaps you can post a screen shot of the 3D window showing the problem in action.

Well, I fixed this. Somehow my user preferences got corrupted. I deleted and created it again with my user hotkeys added. Now the edge ring and loop works fine. Thanks for the input.

I found I needed to create my own user preference name instead of just updating the default Blender preference. When I set the mouse select to Left mouse when using the Blender default and saving as default, the next time I open Blender, the mouse select is back to right mouse and I have to set it again to left. But when I save my settings as a new one using my name instead, it keeps it. I just select my profile name from the splash screen when I start Blender. Weird.