Edge Split modifier not working on export

Im having this model on which i applied an edge split modifier. When i export it as a nif file (model file for Fallout game), there are portions where the edge split didnt work. Not only that but there are parts where the surface gets even darker. I didnt have this problem until now, if i try to export something else it works fine. This means that its not the exporting script thats having problems, its the model itself.
And the normals are not flipped, i even tried a Ctrl + N and got the same thing.

Attachments


Can you post the .blend ? If you are positive it is the model that causes the problem, it’d be easier to fix !

This is what i have. The modifiers are not applied yet

Attachments

VERTI19.blend (1.04 MB)

I noticed that there’s some vertex paint color map there, that oddly correspond to the bizarre lighting from your 2nd screenshot :

http://i.imgur.com/WMKvU.jpg

Try to delete this vertex color map to see if it is the source of your exporting problem (and if you load that model in 2.6x , don’t, instead append it to avoid more problems).

Oh and it’s a 2.49b file, so if you’re opening it directly in 2.5x or 2.6x, don’t do that, instead use File -> Append and in the Object section of that file, select all the object listed.

Opening directly a 2.49b file into 2.5 or 2.6 create some problems, one of them is the disappearance of most sculpt brushes , and who know exactly what other problem it can create.

But using File -> Append instead does not create any problem.

I dont work with 2.5 or other versions, just the good old 2.49b. Its the only version that`s able to export Fallout models using Nif Scripts.
Is there a particular reason for telling me about 2.5 or 2.6 Blender versions?

Because the majority of people use 2.5 / 2.6 and as you didn’t mentionned you were opening the model in 2.49b …
Have you tried deleting your vertex color map in 2.49b to see if it fixes your problem ?

That`s it! All i had to do is delete the vertex color map. Thanks Sanctuary i love you man!