Edit Mode acting like Object Mode.

I can’t see Lines, Faces and Verteces anymore in edit mode, I’m new to Blender and I have followed about 13 Tutorials so far about Controls and Basic Shapes aswell as texturing and UV Editing but none of these told me about it, I Must have accidentially toggled an option on, See Image below :


As you can see, eventhough i’m in edit mode, I can’t see Lines, Faces and Verteces, Little help ? thanks.

It’s not selected. tab to object mode and select it.

You have 2 cylinder type objects, you probably deleted the mesh for the one you have selected.

Ooh, that’s all ? Stupid me, I Need to get used to it, Thanks for the tip :slight_smile: