Edit Mode Adjustments Jumping


I’m new to using Blender so if this is an obvious answer please go easy on me. Whenever I attempt to adjust the vertices, edges, or faces of my work, the first adjustment is way too drastic and it won’t let me make slight, fluid edits. I have already modeled a character before this on blender and it didn’t do that when I worked on it before so I don’t know what I did wrong. Please help me!!


Ensure you don’t have snapping enabled (magnet icon on 3d view header)
Holding down shift key while transforming an object will allow finer control

It was definitely the fact that snapping was enabled, thanks!!!