edit mode and add circle

how do you add the circle as per the viewport your in at the middle of object or at the selectd vextex

sometimes when i add a circle it’s off at an angle where it should not be
and not ceratin how to get back to a more plane circle where it should be when adding


When in edit mode, anything you add will be aligned with the current view. So if your use the MMB to look upside down, the object will be upside down. Make sure you are in the top (Num 7) view before adding anything in Edit Mode. And if you want to circle to be added to a specific point, select a vertex and hit Shift+S and select Cursor to Selection. That will make your cursor snap to that vertex and that will be the center point of anything you will add. Hope that is what you are looking for.

normally that’s what happen but in some cases it does not worl and i was wondering how to reset it back so that when you add it will be as per viewport working in


In Edit Mode I don’t think there is a way to change it. In object mode you can though. Bring down the preferences window and go to Edit Methods. And off to the left you will see Add new objects: near the bottom of the left side. If you want to add something and have it aligned to your current view, select “Aligned to View” and that should take care of it. Hope this is what you are looking for. I don’t think you can change it to work like that in edit mode, it only does align to view.

On the subject of circles, why is it that if you select half the vertices and delete them to give you a semi circle and then extrude and scale it you get a very odd shaped arc yet if you do the same with a full circle you get a neat even extrusion all round?

It all depends on the median point. If you change it to the 3D cursor it will act like a full circle. But the median point takes the average position of all the selected verticies and act like the 3d cursor. But if you choose, with the 3d cursor, where you want the median to be, it will scale towards that. Hope that made sense.

normally it should not if you useth widget axis or global system or local

it should be arc but ounce and while it odes go arcing

not certain what to do yet
hope to find how to get i back straight