Edit mode faster than object mode?

this is what I posted in the Basics and Interface section, and I was redirected here.

today I ran into two problems:

  1. Blender lags. I got 2500 single objects. But initially they were all in one mesh, without lagging, so the vertexcount cant be a problem. It laggs on any (completely empty) layer. With any other file it works perfectly smooth. It even laggs in bounding box mode!!! Until I go into edit mode for one of the objects. Somehow everything suddenly works fluid again, even in textured or solid mode!! Why does this happen? This cant happen to my favourite application!!!
    Any suggestions?

  2. After rendering, and hitting ESC it crashes. Repeatable. When manually switching from the image editor, to the 3D view, it crashes too. I again have no clue about the reason.

Thanks in advance,

So now, I have Internet again, and just rebuild from trunk (today, 14:34), and the Problems are still there. Both of them. My System:
Linux Kubuntu 11.10
KDE Desktop
nVidia GT540m 1 GB
Intel i5 2410m (2*2.3GHz, with boost to 2.9)
8GB of RAM
Blender newest version (it even has bMesh :slight_smile: )
If more is needed, I will add it, just ask :slight_smile:

I hope someone can help me, cause these would be to really bad bugs or whatever.
Thanks in advance,

we are talking about a problem with a single file, a single setup, a single version of Blender?
Could you be more specific about the context?

KDE is a really awkward desktop environment, especially since the 4.x branch, i personal do not recommend it for performance and stability, gnome 2 or XFCE are way better.

Yeah, Im sorry for that, it has got 25432 vertices, divided over 2152 objects. In Object mode I get 4 fps (measured with alt-a), while I get 27 fps in edit mode of one of these objects, in solid mode. The funny thing is that I even only get 4 fps in BOUNDING BOX MODE!!!
I wanted to create one of these typical hexagon scenes, to test the honeycomb generator. I didnt move the hexagons after I noticed the slow fps.

In Object mode:

In Edit Mode:

Yeah, but Gnome does not work too well for me, I will use it on my next setup.

thanks so far

Just a suggestion, you could post up the .blend file. That way others could test it out and report their results to help narrow down where the problem is…


Edit: I just re-read your first post and noticed you’re using a bmesh build…have you tried it in the official 2.62 version without bmesh???.. it could be a bmesh related problem since bmesh still has a ways to go before it’s really ready for use…

The way your Blender behaves seems similar to when you are using a modifier, when the objects on the scene have to be recreated everytime you navigate in your viewport.
I think that this is a normal behaviour using a plugin with untrusted source and that is not official.