edit mode gives some grey lines not editable

Hi
switching to editmode gives some grey lines which are not editable. How can I move/delete those grey lines/vertices?
Many thanks
Michael

It sounds like you either have a mirror modifier enabled or you have parts of your mesh hidden. You can unhide objects/meshes by pressing ALT + H.

or possibly a mesh in another scene is present.