Edit mode / hotkey C ,LSTV ,Glitch ?,Help

Windows 64,Blender 2.57.1

Edit mode / hotkey C

When “limit sestion to visable” is see threw “C” only selects what I am telling it to

When “limit sestion to visable” when its not see threw
If I select some vertices it auto selects radome vertices that I did not select
this is acting like a glith but I am real new to blender

Help
Thanks

Update your graphic card drivers and turn off anti-aliasing in your graphic cards control panel