Edit mode is really laggy

modeling

(Alan47) #1

Hi folks,

I’m experimenting with Blender 2.8 as I’m typing this. I really like a lot of things about this new version, I feel that this is a straight upgrade from earlier versions of blender in all possible ways.

The biggest issue which I’m currently facing is that the regular edit mode is really laggy. Even on meshes with 170k vertices (which is rather moderate in 2019), grabbing and moving a single vertex turns the formerly smooth viewport into a slideshow. No proportional editing or snapping or modifiers enabled, just a raw mesh in edit mode brings Blender 2.8 to it’s knees at the moment.

Interesting side note: sculpting on the very same mesh works totally fine and very smooth. Only edit mode seems to be affected by this.

Is anybody else experiencing this issue and/or knows a workaround for the time being?


(Thanos) #2

yes I have the same problem. like you told it gets laggy and frezzy I cant work with that lagg


#3

It’s a known issue according to the wiki and the devs plan to improve performance for 2.80 stable release:

Note however there are still some missing features and performance problems in the new implementation. Particularly animation playback and moving of vertices in edit mode will be improved before the final 2.80 release, to bring it back to 2.7x level.

You can read more about it here: https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Modeling#Subdivision_Surfaces_and_Multires

Current workaround (for me) is to use 2.79 for modeling / sculpting.