Edit Mode Performance

I’m creating a deep mine in blender and when I’m mapping UV’s in edit mode the edit view lags a lot when I move or rotate it. Is there a performance cap setting I can modify? When I researched it I was told it was under OpenGL settings in the System category in User Preferences.

I’m assuming you’re using Textured Solid setting for that? Yes, it gets slower the more faces/textures you have in view. Try isolating parts of your scene (hiding, local view, etc.) or turn Textured Solid off and switch to Textured or Material shading mode.

But is there a setting that allows for more memory consumption?

go to file > user preferances

check if this is set to a low value. (0 is unlimited)

if not, you can try to play to increase this setting. i dont know what it is, so if you dont see any difference, then set it back to your default.

Memory consumption has nothing to do with that performace issue, and there is no such setting for viewport drawing purposes anyway (well, there is texture size limit, but its purpose is to actually save video memory).

Things affecting viewport drawing in System user preferences are mipmapping, anisotropic filtering, multisampling and VBOs. No magic “be faster” switch. Turning all of them off (but turning on VBOs) may improve performance, but don’t expect miracles.

I hear you. This performance issue hits me right in the manhood. It seems the only way to fix this issue is to utilize the isolation technique you mentioned or upgrade my hardware. Thanks for the help.