(edited) How to stop child particles (hair) from intersecting the emitter?

I made this post 3 days ago, but I’ve managed to get around the issue I had by making a larger emitter, than what is pictured below. I am using a duplicate of the entire upper body of this Daz figure, as an emitter so that the parent curves won’t intersect with the body. Unfortunately, it doesn’t keep the spawned child hair particles from intersecting the mesh:

I don’t know how to prevent this. Is there anyway to stop this from happening?


> I’ve been trying to create particle hair (my first real attempts at this) with Blender 2.81 (E-Cycles version). I have the Hair Tool add-on and intend to convert the particles to curves, and then work with the hair from there, with that. But first I want to try adding a collision setting, to keep the hair from intersecting the mesh I am working with. The figure I am creating hair for is an imported Daz figure. Instead of adding collision settings to the whole mesh itself, I’ve created a form made from her head and shoulders, for the hair to collide with. However… the settings don’t seem to work. I have tried (with Hair Dynamics on), with no effect. Something isn’t right and I don’t know what.
*> *
*>

*
*>
> As you can see, the red hair particles pass through the form I made (selected in white). I’m not sure where to go from here, so I am asking here. Pardon the blurred out nudity, anyway.
*> *
> Any ideas on how to get the collision working properly? I have read that there are bugs with 2.80, but I’m hoping it’s fixed…

Hey Crotalidae,

Hair Tool add-on 2.20 doesn’t recognize children particles, but it has its own “Generate Children” option in the particle edit mode.

Thanks, but I don’t know how that helps me, unless I can use Hair Tool (which I do have) with the existing particle system I already have. I see that I can open use the options for HT in the particle edit mode, as you said, but then I don’t have access to the kink settings in the particles options…

I misunderstood the part with the Hair Tool. Now I see, you are going to convert the particles to curves first.

I am going to look into that

Actually, I abandoned using Hair Tool for the time being, instead focusing on using a purely particles-based system. However, if I can find a good workflow for working with Hair Tool, converting particles to curves, I will do that instead…