Editing stacked shape keys

Load this blend and try rotating or scaling the selected verts. As you will see, they go all over the place.

This is happening because there are multiple active shape keys: CloseLidLo, CloseLidUp and CloseLidUp_CloseLidLo (the key being edited). Disabling the first two shapes results in rotation/scale behaving as expected.

Unfortunately this model is being prepared for export to a third-party format which requires CloseLidUp_CloseLidLo to be relative to those other shape keys, so disabling them is not an option.

Is there something that I’m missing or doing wrong? If not I’ll report this as a bug.