Editing UVs after an unwrap...

Hey guys, I have a couple of questions I’d appreciate any help with:

  1. (My main issue) I have a character model that I’ve used the Unwrap feature on to set up its UVs. I’ve since thought of some optimizations that could be made to the corresponding mesh. I’d like to know if there’s some kind of way to edit the model, and have the changes show up in the UV editor.

A while back with another model I was working on, I got to a point after the initial unwrap, that I realized I wanted to add another piece to the mesh (a separate eye rather than what had been an (admittedly lame) painted-on eye, in this case). I unwrapped the mesh again with the mouse cursor positioned over the 3D Perspective view (“U” key), but the mesh was brought into another, separate UV grid from the one the rest of the mesh’s UVs occupied.

  1. (Peripheral issue) This has been somewhat of a burning question that I’ve wondered about since I began modeling not too long ago. Also, since this is most likely the wrong forum for such nonsense, it can probably be disregarded in most cases. For some reason, I’ve gotten it in my mind that a proper model is composed of only one piece, and the challenge inherit in modeling is getting all the various pieces of anything (doors and lights and sideview mirrors, in the case of a car) to come off of its main piece. I’ve since realized how ridiculous that is, and how much easier it is to model separate pieces. (I never really participated in or carried through with the notion I’ve just detailed; it was just something in the back of my mind, kinda.) So I guess my questions is, if a character is modeled for use in a video game, for example, can its mesh be composed of various pieces (like a body, two separate eyes, glasses, a hip flask, etc…) and still function as one “unit” within the game engine? Though it’s not too important as far as the first question’s concerned, I can clear it up a little because reading back on it now I can see how wicked convoluted it is.

Thanks in advance.

  1. Pin the ones you dont want to move. see http://mediawiki.blender.org/index.php/Manual/Editing_the_UV_Layout#Using_the_Pin_command
    then select all faces and re-unwrap. the new ones will be put inbetween the pinned connecting ones.

  2. Not ridiculous. We have not one, but two concepts for this, called Parents and Groups. See http://mediawiki.blender.org/index.php/Manual/Groups_and_Parenting

Hey, thanks for the reply.

I was posting to try to circumvent what’d happened before because I was on the verge of unwrapping another mesh. Well, I unwrapped it, and the same thing happened. Any new polys I’ve added show up as white in “potato” mode while the texture covers the rest of the mesh. When these white polys are selected in “UV Face Select” mode, the UV Grid that houses the rest of the mesh’s UV layouts disappears and a new one shows up, which I can only guess is because the new polys are seen as a separate object away from the main one labeled as such during the first unwrapping. Any ideas as to how I could merge these two UV layouts into one?

yes. go to your first unwrap, the original, and pin them in the UV window (select all and pin; they get big orange like the head of a pushpin). In the 3d window, in UV Face select, select all (even the white ones) and unwrap the entire mesh again. The new UVs will be put into the UV map. Unpin and adjust as you like to fit the new faces onto the image.

That’s the thing; I did pin the UVs from the first unwrap. I also tried to unwrap again with the mouse over the 3D window (the “U” unwrap, not the “E”, right?). Does it take a while? I might have stopped it prematurely because it didn’t seem like it was doing anything.

Nothing, eh?


If you’re still following this thread, I haven’t come up with a solution but I’ve just realized something that might help: If I select the white polys in the 3D view (In UV Face Select Mode) at the same time I select polys that are showing up in the UV Editor’s grid properly, I can see the white polys selected in the UV Editor. If they’re selected by themselves, that is, not at the same time properly-working ones are (by “properly working”, I mean displaying the part of the texture map they’re currently over in the UV Editor), they show up in a UV Editor grid separate from the main one containing my texture. I’d like them to be merged into one.

hi, sorry, i dozed off there for a minute. I’ve been working on updating the wiki for 2.43, and UVs have improved quite a bit, so its a lot of work. But i had to take a break from that because I’m working on a kick-butt example. So, back to you…As far as taking awhile to unwrap…not really, unless you have something incredibly large and are running an IBM XT. If you could post a blend, it would be faster than me trying to guess what the situation is. Use Polorix.net, it’s blender friendly.

Ok, so you have a UV map and layout, but one for some faces, and another for the rest. SOoooooo, you should be able to, In the 3D window, go into UV Face Select mode. press A to select ALL faces, may have to do it twice. In your UV Image Editor window, you should see the map, at least for the pinned. In the 3D, select Face->Unwrap (U) and choose a method. Now, E in the UV Image editor uses the archimapper, which gives different results, but still results in a valid UV map. You just have to play with it to get what you want. If you have seams, then that’s another complication that should help you. But maybe not.

I will try to keep an eye out for your .blend…

Um, in regards to your previous problem with the eyeball . . .You are aware that the UV map display only displays what’s going on for the currently selected faces, right? I mean, you should have been able to select all the eyeball’s faces, hit unwrap (or project from view or whatever suits you), then select everything in the UV window, scale it down, and throw it into some place that you know isn’t being used by the rest of the UVs, then go back to the 3d window and select ALL the faces and the UV window should then show the untouched original map AND the eyeball stuff all at once?

I don’t mean to be insulting or anything, I’m jeust having a hard time figuring out from what you’ve said if you understand this part of the UV system yet. I didn’t get it right away. (Also hope that my addled brain has managed to explain it decently …)

Try using the live update feature too. if it’s toggled on, unpinned nodes optimize themselves, as you move a pinned node around.

ok, i took some time to recreate your problem. click on a few originally mapped faces in 3D view, then shift click on a new face. in the UV image editor, select all four corners of the new face UV, and scale and rotate and grab it into position, using the original maps as a guide. Repeat for all new faces. Now, when you select All Faces in 3D, the whole good map should be there. You then have to remove double UVs by welding their mates, see the wiki on this, but you turn on the option that shows you both UVs, and then Stitch them together.

If there are a lot of new faces, I dont see how to do it without just re-unwrapping the whole thing again. sorry. the problem is the new faces unwrap to the first map by default to full size, overlaying the whole map, once they are deleted from the second unwrap. But, if there are alot of them, it get veryyyyyyy teeeeeedious. .

Thanks for the responses, guys. I haven’t quite figured it out, but through some happenstantial combination of your suggestions, I was able to get the UVs from the second unwrapping together with those from the first. I started to weld the UVs together, but the texture map under which the new UVs (the ones from the second unwrap) were placed didn’t “acknowledge” them… the texture didn’t show up on those particular polys. Then I did the “E” unwrap with the cursor over the UV Editor window just for experimentation’s sake, and the remaining “wild” UVs that I hadn’t yet welded (I only welded a few out of the 10 unrecognized polys, anyway), and, as I mentioned in a previous post, all of those polys were again reconstituted into the main mesh, but without the benefit of having the damn texture show up on them for some reason. They’re white, as before, surrounded by the colors of the correctly working polygon-UV relationships.

So I’m at a bit of a loss; there are so many controls in Blender (it’s not the most intuitive program), and I’m hearing so many suggestions, that I just don’t know what to attempt.

I don’t want to upload the .blend, honestly, because I just don’t want to share it right now. I don’t mean any offense, but it’s something I’m in the process of working on (or would be, if this’d work).

Thanks again for the help so far.

Ah, I think I get where it may be losing you. Each face can have it’s UVs assigned to a different image, so the newly created faces are probably assigned to nothing (which would also make them look different in UV face select mode.) Try doing a select-all in UV mode and selecting the image you are using in the UV Image Editor window again, from the little drop-down box. That should set everything that’s selected to actually USE that image.

Hope I’m being sufficiantly articulate to help :).

Star Weaver:

Yeah, I’d say you’re articulate enough. I see what you’re saying, and that’s what I did the first time I ran into this problem, but I’d like to avoid that if possible because that’d double up the number of textures, and therefore the memory taken up by textures, correct? And, it’d make it awkward to edit the texture because I’d need to do it in two places, and make them match. Thanks for the suggestion, though.

Please dont be embarrased about your mesh. I’m not wearing any pants now, and I’m not embarrased. So, go ahead and show us. Polorix is free.


I’m not embarrassed by it. I’m sorry I wasn’t more clear about that. It just represents some ideas that I’d rather not “let out” if you understand what I mean.

Any ideas about the last symptoms I posted?

I just thought I should post to clarify that I’m not trying to accuse anybody of stealing ideas (though I’m sure that’s how it’s coming across). If nobody can help with the information I’ve given, I can try to replicate the problem with another file and post that.

No, actually, what I meant, was that once you select all the faces and select an image from that dropdown, then all those faces will reference that one image. And you can edit them all at once, as long as they’re a part of the same object.

As far as I understand, you can edit all the UVs for any number of disjoint meshes at the same time as long as they’re all part of the same object, because you can only enter face mode “on” one object at once.

(This means you can go into edit mode and keep hitting Add -> Whatever to add submeshes, then unwrap all the different floating bits onto the same UV space …)

You would have to edit the texture in two places (in the same file), but that shouldn’t be too bad for something like eyes because you can make the eye mesh fold under the hole-in-the-face mesh such that the seams are irrelevant.

(You CAN edit UVs for faces that are assigned to different textures on the same mesh too, but it can only show you the image for one set at once …)

Ok, so I figured it out. In 3D, UV Face Select mode, Select the new faces, and unwrap them using the same options as the original. In the UV editor, select all those UV’s and MOVE THEM off to the side (make sure UV->layout clipped is Off). Then go back to the 3D window and select ALL faces. The two UV maps will be superimposed on one another. Load up your image and adjust UV’s so they can be stitched (there’s an option, i forget which, check the wiki) to highlight paired UV’s when selected-makes stitchin easy).


Thanks a lot man; that did it. Apparently one of the major problems I had was not re-loading the image to acknowledge the newly unwrapped UVs. But once I did (after taking your suggestion to move the new ones off the UV grid), that did the trick.

Thanks again, guys, for helping me with my little problem there.