Eevee: Depth of field makes rendering 63 times slower. Normal?

I was following a tutorial, and the tutor said Eevee rendering was so fast (his graphics card was slightly faster one than mine, but not that drastically faster). But when I tried to render the animation, it was slow. It seems that DOF is the problem. Without DOF, the first scene took 0.62 seconds to render. With DOF, it took 39.61 seconds. Is this normal?

My Blender is 2.83, and I don’t know what exactly his version is but his one must be at least 2.80 (judging by the UI). The Aperture values were the same as the tutor’s: 0.1, 0, 0, 1.000. My Eevee sample was 64.

With Cycles (sample 128, adaptive), 24.86 seconds without DOF, 24.81 with DOF.

1 Like

Yes, and not only depends on render samples. Also from the F-Stop values in Camera settings and from Render Tab > Depth of Field > Max Size (higher values make it heavier)

1 Like

That value was 100px, which I think is the default one probably. Anyway, as I wrote, in Cycles, DOF did not make much of a difference in rendering time; why does it affect Eevee so much? At this state, I have no reason to use Eevee for this render, because the only reason one would use Eevee is speed, and Eevee with DOF (39.61s) is actually taking longer to render than Cycles with DOF (24.81s).

1 Like

They are two complete different render engines. There are plans to rewrite and improve DoF for Eevee.

Yes, 100px is the default, you try much smaller values and you see if it satisfies you.
Just in case, what is your graphics card and how much vRAM does it have? If you are close to vRAM limits and it exceeds vRAM usage, this can get much worse.

Probably it was not the vRAM. It was a simple scene with one phone object and ground and nothing more. The vRAM load was about 30%, on the Task Manager.

Thanks - I had a similar problem, and reducing the max size in Render was the solution.